2ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

php5これでCGIはphp1色の時代へ

1 :nobodyさん:02/04/12 16:42 ID:DpXGWeMS
ふふ

2 :nobodyさん:02/04/12 16:48 ID:???
そうか

3 :nobodyさん:02/04/12 16:55 ID:???
PHPって簡単でいいよね。CやPerlは諦めた漏れでも
掲示板作れるもの

4 :かおりん祭り ◆KAORiAk2 :02/04/12 19:26 ID:???
〜oノハヽo〜 / ̄ ̄ ̄ ̄ ̄ ̄ ̄
  ( ^▽^) < 新スレおめでとうございま−す。
= ⊂   )   \_______
= (__/"(__) トテテテ...


5 :nobodyさん:02/04/12 20:11 ID:???
5っていつでるの?

6 :モナー:02/04/12 20:58 ID:???

             o    モナーからのお知らせ    o
            / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄/
           /  超ローリスク!超ハイリターン! /
           /   iモードサイトオーナー必見!   /
          /  出会いサイトオーナーシステム /
          /                      /
         /http://www.lo-po.com/owner/?183 /
         /                      /
        / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄/
  ∧_∧  /                      /∧_∧
 ( ^∀^) /                      /(^∀^ )
 (    )つ                     ⊂(    )
 | | |                         | | |
 (__)_)                        (_(__)



7 :nobodyさん:02/04/12 21:54 ID:nBlG/qG2
>>5
2002年末
>>3
できるが、実装がjavaに近くなってきているので段々敷居が高く
なってきているとおもはれ。
それでも、らくちんだか。

8 :nobodyさん:02/04/13 09:27 ID:???
PHPをCGIで使うヤツなんているのか。

9 :nobodyさん:02/04/13 11:07 ID:bVQnIHyX
phpってなんか深みがないような気がするんだよねぇ。。。
簡単なもの作るのはいいんだろうけどさあ。


10 :nobodyさん:02/04/13 11:45 ID:???
     ____
    /∵∴∵∴\
   /∵∴∵∴∵∴\
  /∵∴∴,(・)(・)∴|
  |∵∵/   ○ \|
  |∵ /  三 | 三 |  / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
  |∵ |   __|__  | <  >>1 CGI?君はそんな無駄な事にPHPを使っているのか(ゲラ
   \|   \_/ /  \_________________
     \____/
   ______.ノ       (⌒)
  //::::::::|-、 ,-/::::::ノ ~.レ-r┐
/ /:::::::::::|  /:::::ノ__ | .| ト、
| /:::::::::::::::| 〈 ̄   `-Lλ_レ′
レ::::::::::::::::::|/::: ̄`ー‐---‐′


11 :nobodyさん:02/04/13 12:47 ID:UCfSt7fS
恥ずかしい>>1がいすスレはここですか?

12 :nobodyさん:02/04/13 14:34 ID:qK5LnvR5
いすスレ

13 :nobodyさん:02/04/13 19:01 ID:Ysvwa1Gv
     ____
    /∵∴∵∴\
   /∵∴∵∴∵∴\
  /∵∴∴,(・)(・)∴|
  |∵∵/   ○ \|
  |∵ /  三 | 三 |  / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
  |∵ |   __|__  | <  いすスレって何?
   \|   \_/ /  \_________________
     \____/
   ______.ノ       (⌒)
  //::::::::|-、 ,-/::::::ノ ~.レ-r┐
/ /:::::::::::|  /:::::ノ__ | .| ト、
| /:::::::::::::::| 〈 ̄   `-Lλ_レ′
レ::::::::::::::::::|/::: ̄`ー‐---‐′

14 :かおりん祭り ◆KAORinK6 :02/04/13 20:39 ID:???
         。◇◎。o.:O◇◎。o.:☆
        。:゜◎〜oノハヽo〜☆。∂:o゜
       /。○。∂( ^▽^)O◇。☆Oo
     /| ̄ ̄ ̄ ̄.∪ ̄∪. ̄ ̄ ̄ ̄ ̄|
    /  |新スレおめでとうございまーす|
  ▼    |_____________|
∠▲―――――☆∂io◇◎。oO☆o





15 :nobodyさん:02/04/14 00:56 ID:3kufQelu
php死ね

16 :nobodyさん:02/04/14 02:10 ID:???
>>12
いすスレってなんだろう?

17 :nobodyさん:02/04/14 08:43 ID:gifPaPXz
恥ずかしい>>11がいすスレはここですか?

18 :nobodyさん:02/04/14 08:56 ID:gYLhBrHd
         。◇◎。o.:O◇◎。o.:☆
        。:゜◎〜oノハヽo〜☆。∂:o゜
       /。○。∂( ^▽^)O◇。☆Oo
     /| ̄ ̄ ̄ ̄.∪ ̄∪. ̄ ̄ ̄ ̄ ̄ ̄|
    /  |いすスレおめでとうございまーす|
  ▼    |______________|
∠▲―――――☆∂io◇◎。oO☆o


19 :nobodyさん:02/04/14 12:54 ID:vCJf96td
名いすスレの予感。

20 :nobodyさん:02/04/14 21:07 ID:6DHe9XM+
3月27日にPHP5のセミナーがあったね。
誰か行った人いる?

21 :nobodyさん:02/04/14 21:20 ID:gifPaPXz
>>20
そんなんあったんだ。。
行きたかったー、何処であったの?。


22 : ◆AngelBlk :02/04/14 21:37 ID:???
PHP5の前に、とりあえず4.2・・・。
PHP-devel ML(JP)読んでるけど、
5はかなり大きな変更になりそうだね。

23 :nobodyさん:02/04/14 22:14 ID:???
>>22
要約キボン

24 : ◆AngelBlk :02/04/14 22:40 ID:???
>23
usersMLの方だけど。
わかりやすくまとめてあったので。

http://www.nishimoto-site.net/archiver/ML/php-ML/200203/msg00250.html

個人的に、クラス周り強くなるのはうれしいかも。

マルチバイト対応とかはまだ決まってないことも多いみたい。


25 :nobodyさん:02/04/15 00:09 ID:4JLQzEQq
php5はwebだけじゃなく普通のアプリも作れるってね

26 :nobodyさん:02/04/15 00:22 ID:???
>>24
サンクス。
なんかどれも「今まで無かったのかよっ」とつっこみいれたくなるモノばかりだな…。


27 :nobodyさん:02/04/15 00:33 ID:/palSQI1
>>21
飯田橋の東京コンファレンスセンターです。

28 :nobodyさん:02/04/15 00:56 ID:tsxU1zCu

今年の2月以降に製造された RX-2001 が、
たったの 9700 円!?↓
http://www.bidders.co.jp/user/1023585

買おうかな。

29 : ◆AngelBlk :02/04/15 08:32 ID:???
>26
まあ、今まで
実装する=それが仕様
ってスタイルできてて、このあたりのことをやる余裕が
なかったのかもね。

まあ、PHP5でようやく言語としてまともになってくるかも。

下位互換性だけど、PHP-dev..JP MLで
<?php version "5.0"?>
こういう話もあるみたい。
まあ、本家のほうで受け入れられなければ実現しないと思うけど
下位互換性は低いよりは高い方がいいよ。

30 :nobodyさん:02/04/15 12:38 ID:???
いすスレage

31 :nobodyさん:02/04/15 12:39 ID:???
sageちまった。

いすスレだ。

32 :nobodyさん:02/04/15 12:46 ID:???
             o         案内          o
            / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄/
           /                       /
           /   ここが、    /
          /  いわゆる「いすスレ」です   /
          /                       /
         /     /
         /                      /
        / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄/
  ∧_∧  /                      /∧_∧
 ( ^∀^) /                      /(^∀^ )
 (    )つ                     ⊂(    )
 | | |                         | | |
 (__)_)                        (_(__)       


33 : ◆AngelBlk :02/04/15 13:51 ID:???
貼り忘れ。

http://www.avantexchange.com/php/phpoopbook.html

PHP5の情報ならこういうのも。

34 :nobodyさん:02/04/15 18:14 ID:???
オブジェクト指向とかって良く言われるんだがそれってなに?
Javaの時も散々言われたが結局なんのことかわからんし。
よく電気スタンドに例えてONするとかOFFするとか例えられてるけど
どういうときに使うのさ?

35 :nobodyさん:02/04/15 19:50 ID:???
カプセル化するときに使う。

36 :nobodyさん:02/04/15 19:50 ID:???
というか、今でもphpはクラス扱えるはずだか・・・

37 :nobodyさん:02/04/16 00:52 ID:???
PHPいいわ。ジャヴァやスィやペルルなんて全くわからないけど
コレは簡単。息子に聞かなくても、もう大丈夫。
これからはPHP,CSS,Flashのトリプルイーズィープログ゙ロマーこそ最強。
わけわかんねーからザヴァとか逝っていいよ。Javascriptは良し。

38 :nobodyさん:02/04/16 13:33 ID:FuYFDDkp
>>37
オブジェクト指向を取り入れた時点でイバラの道を突き進むことが予想。
PHPの開発にUMLやらデザパタが取り入れられるようになるのだろうか…。


39 :修正屋:02/04/16 14:29 ID:???
             o         案内          o
            / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄/
            /       〜 ご案内 〜       /
           /                       /
           /  ここが、               ./
          /    いわゆる「いすスレ」です   /
          /                      /
         /                      /
         / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄/
  ∧_∧  /                       /∧_∧
 ( ^∀^) /                       /(^∀^ )
 (    つ                       ⊂     )
 | | |                         | | |
 (__)_)                         (_(__)

40 :nobodyさん:02/04/16 14:32 ID:???
             o                      o
            / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄/
            /       〜 ご案内 〜       /
           /                       /
           /  いすスレワショーイ           ./
          /      いすスレワショーイ       ./
          /          いすスレワショーイ   ./
         /                      /
         / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄/
  ∧_∧  /                       /∧_∧
 ( ^∀^) /                       /(^∀^ )
 (    つ                       ⊂     )
 | | |                         | | |
 (__)_)                         (_(__)

41 :nobodyさん:02/04/16 22:53 ID:???
PHPってなんであんなにやり易いんだろう。
Perlとかソースみてると頭が痛くなる。

42 : ◆AngelBlk :02/04/17 00:30 ID:???
>38
デザインパターンに関しては
ttp://www.pat.hi-ho.ne.jp/dimension/
ここが結構色々書いてあって面白い。

まあ、オブジェクト指向で「作れるようになる」のと「作れない」では
やっぱ作れるようになったほうが選択の幅は広がるし。
別に使いたくなければ使う必要無いんだしいいのでは?

//まあ、盲目的にオブジェクト指向って言われると萎えるけど・・・。
//仕事がらみだと、盲目的にJAVA押してくる人がいて困る(苦笑

43 :sage:02/05/13 19:40 ID:???
しんぱいないよ
そのうちあぱっちにでふぉでくみこまれるようになるから わら

44 :nobodyさん:02/06/01 23:42 ID:2HMrwkAK
>>41

PHP で頭痛くならないってたいしたもんだよ。Pear のソースなんて
書き手のオナニーだろ。(あんな使いづらい下手糞な設計でも PHP 標準
でついてきてしまうんだから、参った。)

45 :nobodyさん:02/06/01 23:44 ID:2HMrwkAK
言語仕様が最初からウンコ

46 :nobodyさん:02/06/02 09:40 ID:???
>44-45
わかりやすい自作自演だなw
正直笑った。
一体いつの書き込みにレスしてるんだよ、って感じだし。

47 :名無しさん:02/06/02 09:50 ID:???
>>46
別に自作自演ではないと思われ

48 :nobodyさん:02/06/06 05:24 ID:ASF2AT4g
Pear??

いすスレ・・・
な予感

49 :名無しさん:02/06/06 09:30 ID:???
>>44
Pearのなんのソース?
よく使うHTML/IT.phpはまともだと思うけど・・・。
PHPDocのコメントがウザイときはあるけど、あれはPearの規約だったはず。

50 :デフォルトの名無しさん:02/06/06 22:27 ID:FSJ1DXvz
phpでCGIを書けるんですか?

51 :nobodyさん:02/06/06 22:32 ID:???
>>50
馬鹿でつか?

おまえはCGIを理解してるのか小一時間………

52 :nobodyさん:02/06/06 23:47 ID:???
>>50
かけます。が、>>51がなぜそこまで怒っているのか
わかりません。

53 :nobodyさん:02/06/07 00:02 ID:5SM8C6xZ
phpにもbeanみたいなもんがあったら便利だと思う。

54 :nobodyさん:02/06/07 00:06 ID:???
>>51
おまえは本当に小一時間問いつめたいのかと小一時間問いつめたい
小一時間て言いたいだけちゃうんかと

55 :nobodyさん:02/06/07 10:45 ID:???
PHPで*CGI*を書くヤシなんてこの世界にいったい何人居るだろうか?

56 :nobodyさん:02/06/07 19:19 ID:???
メーリングリスト読む限りでは
いくらでも居るようだが。
レンタル鯖にもCGIとしか使えないのもあるようだし。
世の中Apache以外のWebサーバはいくらでもあるし。

57 :nobodyさん:02/06/09 15:11 ID:???
ネタネタにマジレスカコワル!!

58 :nobodyさん:02/06/09 21:40 ID:???
>>57
( ´,_ゝ`)プッ


59 :nobodyさん:02/06/17 06:42 ID:SQn/DO9h
デストラクタ、(゜д゜)ホスィ

60 :初期不良:02/06/17 09:46 ID:HW2HvEAV
>>56
マルチユーザで使う場合は正直言って CGI 版で使うしかないよね。
suexec で各ユーザごとのセキュリティを確保せにゃならんし。
safe モードを使うにしても、サーバが提供する標準 CGI として
カウンタなどを提供するときとかも CGI で言うところの実行できるけど読めない、
と言う状態を作らなきゃいけないけど、モジュールの状態だと
include, require できるけど読むことはできない、と言う状態は
作れないし...

61 :nobodyさん:02/06/17 20:00 ID:???
つーかPHPってCGIじゃねーだろ。

62 :nobodyさん:02/06/18 02:55 ID:B3GB06nC
>>49

Mail.php を見よ。無意味な Abstract Factory が拝めるぞ。

63 :age:02/06/18 12:51 ID:6aILrMH2
the Zend Engine 2 (php5 alpha) Available
http://www.php.net/

age


64 :age:02/06/18 12:53 ID:6aILrMH2
>59

<?php

class MyDestructableClass {
function __construct()
{
print "In constructor\n";
$this->name = "MyDestructableClass";
}

function __destruct()
{
print "Destroying " . $this->name . "\n";
}
}

$obj = new MyDestructableClass();

?>

65 ::02/06/19 16:19 ID:E+sAV3pS
いすスレ

Pearマンセー


66 :nobodyさん:02/11/20 22:21 ID:???
メソッドのオーバーロードはまだ実装されないのですか?

67 :nobodyさん:02/12/12 17:01 ID:???
>>66

68 :bloom:02/12/12 17:04 ID:qmV6yVXd

http://www.agemasukudasai.com/bloom/

69 :nobodyさん:02/12/12 19:48 ID:???
レアスレですな。php4で時代が来ましたね。

70 :nobodyさん:02/12/14 00:03 ID:???
機能のまえにPHPっていうダサい名前をなんとかしてくれ。
図書館でPHPの本を借りたくてPHPで検索すると
PHP研究所の本がうじゃうじゃでてきて探せたもんじゃない

71 :nobodyさん:02/12/16 21:56 ID:8ofVCSXs
>>70
Rubyに改名すべきだと思います。

72 :nobodyさん:02/12/21 19:55 ID:???
          l≡l   .l≡l
          |:::└┬┘:::|
          |:::┌┴┐:::|
/ ̄ ̄\   ノ::::::丶 /:::::::\.   / ̄ ̄\
| 記念 .> (::(,,゚Д゚)(゚ー゚*)::) < パピコ .|
\__/   |:∪::::| |::::∪::|.   \__/
       〜((((:::::))(((:::::)))〜
         ∪ ̄U U ̄∪

73 :nobodyさん:02/12/22 00:42 ID:???
>71
RubyがPHPに改名すればそれもいいかもな

74 :nobodyさん:02/12/24 15:00 ID:nojs+KEU
>>70
いざプログラミングのPHPのみに絞り込むと
全然ヒットしない罠。
Perlの本だと少しはあるのに・・・

75 :nobodyさん:02/12/24 23:06 ID:???
いっそPHSにしたらどうか。

76 :nobodyさん:02/12/24 23:34 ID:???
>>75 そのSは何者で?

77 :nobodyさん:02/12/25 02:52 ID:???
>>75
寒い。SSL対応PHP?(意味無し) いやSSI対応PHPファイルとの区別にするんかい?
PHPあればSSIいらんかな?


78 :nobodyさん:02/12/25 03:04 ID:???
>>34-36 >>37 >>42
PHPでオブジェクト指向やるなら
いっそのことPHPやめてTomcat(JSP + Servlet) + strutsのほうが開発効率高まるんじゃないかい?

HTML内にPHPコード埋め込むのやりすぎるとだんだん気持ち悪くなってくるし、JSPでもHTML内にJavaコード(スクリプトレット)埋め込むと同様に気持ち悪くなる。
そこでServlet と非ServletなJavaユーティリティクラス、Beanクラスを用意してカスタムタグライブラリを自作するとコードが読みやすくなりすっきりしてコーディングが楽になる。
しかしそういうもの自作するの面倒なので、strutsを使うんじゃ。
よく使いそうなタグライブラリも既に用意されて楽でいいわ、
Beanの作成もServletに相当するクラスも作成も継承するだけで非常に楽でいいわ、
JSPファイルも、 <% %> (PHPの <? ?> )なんてキモイコード一切書かなくて済むわで、
すべてタグだけでコーディングできるて最高!



79 :nobodyさん:02/12/25 08:06 ID:h4k+uv64
http://www.s55.net/~paka/
FFAのPHP化 βテストのため
テスター募集中

マルチすんまそ

80 :nobodyさん:02/12/25 09:38 ID:???
PHPの画像モジュールでjpgサムネイル作ると激しく色褪せどうにかして最高!


81 :nobodyさん:02/12/25 12:30 ID:JczkoUjR
GDのバージョン下げろ

82 :nobodyさん:02/12/25 19:48 ID:???
ところでPHP5ってどこにあるよ?

83 :nobodyさん:02/12/26 18:31 ID:FAw+iTTP
RubyがPHP
PHPがRuby ということで

これからは Ruby の時代だよな?

84 :nobodyさん:02/12/27 00:37 ID:???
>>82
まだ、リリースされてないんじゃないのかな?

85 :nobodyさん:02/12/31 01:41 ID:???
>>情報サンクスコ!
そりゃそうと、スナップショットのミラーサイトにはphp5ってディレクトリが
あるけんが、その中にはWin32バイナリのphp-4.3.0-dev-zend2しかない。
っちゅー事はPHP4.3.0からPHP5ってことかいな?
PHP5.x.xっていうリリースのほうが正解っぽいと思うんだけんども。
以上、独り言ですた。

86 :nobodyさん:02/12/31 01:43 ID:???
あんぎゃー
>>85内の
「>>情報サンクスコ!」
は、
>>84
情報サンクスコ!」
とお読み変えくださいまし。

逝ってきまつ。

87 :nobodyさん:03/01/13 03:18 ID:???
PHP5.0.0-devが出てきたね。

88 :nobodyさん:03/04/02 22:48 ID:???
OO言語へと歩を進めるPHP5
http://slashdot.jp/developers/

--

もうだめぽ

89 :nobodyさん:03/04/03 20:51 ID:o2kN9CQj
>OO言語へと歩を進めるPHP5

Ruby最強ということが証明されますた

90 :nobodyさん:03/08/03 19:44 ID:9uE8xfZj
ローカライズオプションから
--without-pgsql
--without-mysql
が無くなったみたいだけど、必要無いの?

91 :nobodyさん:03/08/03 20:27 ID:???
phpっていいね
Perlのオブジェクト指向は正直意味不

92 :nobodyさん:03/08/04 02:48 ID:???
そんなこと言うなっ。
Perlを使ってる人もいるんだぞ。

93 :nobodyさん:03/08/04 19:37 ID:IP9MFG+G
>>55
>PHPで*CGI*を書くヤシなんてこの世界にいったい何人居るだろうか?
PHPはほとんどのレンタルサーバーではCGIとしてしか動かせません。
よって職業でやっている人以外ほとんどの人はPHPをCGIとして使ってます。
CGIのPHPはPERLより遅いです。

94 :nobodyさん:03/08/04 21:48 ID:???
>>93
日本だとな。
海外だとPHP使えるところも多い。

95 :91:03/08/05 17:27 ID:???
>>92
わっはっは
しかし俺様phpよりPerl派やねん

96 :nobodyさん:03/08/06 14:37 ID:???
PIっていってたころのPってPerlのPだったんだよな・・・
どうでもいいけど。

97 :nobodyさん:03/08/15 15:03 ID:tL1+btHX
せぷてんばーれいん

98 :山崎 渉:03/08/15 22:28 ID:???
    (⌒V⌒)
   │ ^ ^ │<これからも僕を応援して下さいね(^^)。
  ⊂|    |つ
   (_)(_)                      山崎パン

99 :nobodyさん:03/10/17 01:29 ID:???
っていうか,2003年もあと2.5ヶ月だが,ちゃんと5はでるんでしょうか?

100 :100:04/02/23 00:25 ID:???
ついにPHP5.00 beta-4が出た訳だが、
RCも4くらいまで出て正式リリースだろうから
あと半年くらい待つのか。

101 :PHPは何の略?:04/02/24 16:05 ID:8sqa0ZxI

P ( ´,_ゝ`)プッ
H ヘタレが。
P (ププププププ


102 :nobodyさん:04/03/20 16:11 ID:2qC9lb1x
PHP5 RC1 キタ━━━━(゚∀゚)━━━━ッ!!!

103 :nobodyさん:04/05/16 04:07 ID:r9jK3d8C
PHP5キタ━━━━━(゜∀°

104 :nobodyさん:04/05/17 22:56 ID:???
なんか盛り上がってないな・・・
それともみんなコーディングに夢中?


105 :nobodyさん:04/05/18 11:18 ID:???
PHP 5.3.6 まで様子見。

106 :nobodyさん:04/05/18 12:58 ID:???
PHPのオブジェクトって参照じゃ無いんだろ?
終わってるよ

107 :nobodyさん:04/06/07 11:08 ID:LMdbkg5Z

>>106
教えて君で、すんまそ。「参照じゃない」という文章の
意味が分かりませんです。オブジェクト指向は素人なもんで。

こんなことで良いのかのう>わし



108 :nobodyさん:04/06/14 16:39 ID:???
>>106
PHP5では参照渡がデフォルトに成増。

109 :nobodyさん:04/06/14 21:49 ID:???
php5のredhat9用のsrc.rpmが落ちてる所をご存じありませんか?

110 :nobodyさん:04/06/23 21:02 ID:???
>>108
マジ?知らんかった

111 :nobodyさん:04/06/30 02:08 ID:???
PHPにもアプリケーションサーバみたいな仕組みがほしいとこだな。

112 :nobodyさん:04/07/11 20:28 ID:C+Tpd+UA
現状、PHP5で動くテンプレートエンジンってあるんですか?

113 :nobodyさん:04/07/16 01:52 ID:aAWd7JBA
http://pcweb.mycom.co.jp/news/2004/07/14/007.html
出たね

114 :nobodyさん:04/07/17 02:07 ID:???
コネクションプールの辺りはエエ感じにならんのか?

115 :nobodyさん:04/07/17 21:25 ID:B0b4Kph8
>>105
わらた

116 :nobodyさん:04/08/10 18:08 ID:???
配列も参照にしたらいいのにな。

117 :nobodyさん:04/08/14 15:19 ID:???
%20%20a

118 :nobodyさん:04/08/15 10:10 ID:yO+rm/Sg
phpunitがPHP5ではうまくつかえん。
だれかよい方法をおしえてくれ。

119 :nobodyさん:04/08/15 13:19 ID:???
PHP5 用に修正するか、新たに作ってうpすれば尊敬されるよ。

120 :118:04/08/15 15:20 ID:???
>>119
PEARにPHPUnitが含まれていることがわかりました。
(自分が見てたのはphpunit.sourceforge.comのほう←ふるい)
そっちを使うことにします。

121 :nobodyさん:04/08/20 04:31 ID:???
PHP5全然使われてないよね。
失敗だったの?
OO廻りがだいぶまともになっていいなあと思ってたんだけど。

122 :nobodyさん:04/08/20 09:13 ID:???
>>121
普通に考えてまだ使わんだろ

123 :nobodyさん:04/08/20 10:36 ID:???
>>121 >>122
人柱とゆーかなんとゆーか
作成元不明なPHP4の<S>改修</S>作り直しで使うことになった
幸運を祈ってほしい鴨

#その上、元のは眩暈がするほど素敵なコードが並んでたので使えない

124 :nobodyさん:04/08/20 13:23 ID:???
眩暈 げんごろう?

125 :nobodyさん:04/08/20 18:18 ID:???
>>123
うわー、つらそうなパターンだ。
元のコードがサバのエラーログを汚しまくりでないことを祈るよ。


126 :nobodyさん:04/08/21 08:52 ID:???
眩=眼花(目がかすみチラチラすること)
暈=頭がまわる感じがするもの
眩暈、目眩、頭眩ともいう。めまい。

127 :123@コーディング中:04/08/21 12:16 ID:???
simpleXML の設定で Schema support が Enabled になってたので、
valid なXMLを読ませてみた(simplexml_load_file)
ルートノードは作られるものの、どうも子ノードができてない様子

well-formed にするとうまく動作したので、とりあえずこの方向で続行
名前空間の問題かもしれない、後でちゃんと確認すること>自分(ぉ

#こーゆー(人柱的)報告がスレ違いだったらすまそ

128 :本7:04/08/22 14:21 ID:rOZc6IHp
PHP4と同居できない理由てメモリプールとかの関係か?


129 :名無しさんに接続中…:04/08/22 18:50 ID:???
暫くはPHP4を使いながら様子見。


130 :nobodyさん:04/08/22 20:27 ID:???
5.1.xになるまでは様子見

131 :nobodyさん:04/08/23 09:49 ID:???
5.3.9になるまでは様子見

132 :nobodyさん:04/08/23 15:00 ID:Z72wSyFR
>131
3.9になる前に4.0になってしまったら
一生使えませんね^^

133 :nobodyさん:04/08/23 19:56 ID:???
上げてまで言うことでもありませんね

134 :nobodyさん:04/09/01 04:37 ID:???
PHP5.0.1 FreeBSDで、
http://jp.php.net/manual/ja/ref.simplexml.php
なかんじでXMLをいじってるのですが、
<movies>
 <movie>はげ</movie>
 <movie>ふが</movie>
 <movie>ふに</movie>
</movies>
の場合と、
<movies>
 <movie>ほげ</movie>
</movies>
だけの場合のどちらでも、
<movie>の中身をとりだしたい(前者の場合は配列で)のですが、
複数ある場合を想定してforeachを使うと単数の場合にエラーとなり、
単純に$xml->movies->movie とやると、複数のうち最初の一つ(つまり「はげ」)
しか取得できません。

同じコードで、どっちにも対応できるようにするにはどうすればいいのでしょうか?

135 :134:04/09/01 16:01 ID:DiPaFBrX
どなたかplease....

136 :nobodyさん:04/09/01 17:32 ID:???
(´-`).。oO(なんでネタスレで質問するのだろう・・・)

137 :nobodyさん:04/09/02 23:29 ID:???
だってphp5のスレ他に無いし

138 :nobodyさん:04/09/03 05:09 ID:???
あるよ。検索には引っかからないと思うけど。

139 :(^^):04/09/07 08:59 ID:nvETGJeH
    (⌒V⌒)
   │ ^ ^ │<これからも僕を応援して下さいね(^^)。
  ⊂|    |つ
   (_)(_)                      山崎パン




140 :nobodyさん:04/09/09 19:17 ID:???
>>134
単純に型調べて判断してもいいし、いくらでやり方あるだろう

141 :nobodyさん:04/09/12 23:17:20 ID:???
>>134
試してないけど、
foreach($xml->movies->movie as $movie) {
処理;
}
でエラーが出るってこと?

142 :nobodyさん:04/09/16 11:30:23 ID:Bi27wS6q
phpでCGIなんて時代遅れもいいところなスレになってしまったな

143 :nobodyさん:04/09/16 13:40:59 ID:???
>>142
じゃあ、今は何がいい?

144 :nobodyさん:04/09/16 23:20:01 ID:???
CGI でない PHP とか

145 :nobodyさん:04/09/17 20:43:26 ID:???
あっそ

146 :nobodyさん:04/09/27 12:10:50 ID:zhTjX9/1
>>144
そのとおり

147 :nobodyさん:04/10/11 19:35:59 ID:BPCPjWr+
PHP5のマンモス本が出てたので買ってみたが,
リファレンスのページがすさまじく使いにくい。


148 :nobodyさん:04/10/11 22:20:44 ID:???
えー?今度はWeb公開無いのー?

149 :nobodyさん:04/10/17 09:30:21 ID:???
失敗だったってことでしょ

150 :nobodyさん:04/12/03 03:07:41 ID:MyE6PQvS
『PHP5逆引き大全 500の極意』
http://www.amazon.co.jp/exec/obidos/ASIN/4798008850/

これってまだ見てないのですが、良さげでしょうか?

マンモス本のPHP5は、アマゾンのカスタマーレビューだと、
オブジェクト指向の説明が足らない!とか書いてありますね。。。

151 :nobodyさん:04/12/03 16:44:04 ID:Roli/AQD
っていうか、Webシステムにオブジェクト指向は要らない。
少なくとも、「逆引き大全」とか読むレベルでは。

152 :nobodyさん:04/12/04 14:24:32 ID:???
>>151
確かにオブジェクト指向っぽい作り方をしてるだけっていうか
ほとんどサブルーチンわけしてるだけだからね

153 :nobodyさん:04/12/04 15:06:14 ID:???
むしろ、オブジェクト指向を絶対視して、すべてをオブジェクト指向で書くのがすばらしいという空気が残っているのが害。
Webアプリケーションの構造をむりやりオブジェクト指向にしたところで、やってはいけない分析をしてしまうのがオチ。

154 :nobodyさん:04/12/04 17:42:30 ID:???
>>153
それあるよね
オブジェクト指向を導入した際の
メリット・デメリットをはっきりさせないと。

まぁ流行の単語とかはどうしても
勘違いというか上辺の知識だけの人がでてくるよね

155 :nobodyさん:04/12/08 21:26:57 ID:???
何がPHP5でCGIはPHP一色の時代だ、バカも休み休み言え。
まだまだPerlで書かれた素晴らしいスクリプトが山ほどあるのに、
それをPHPに全て移植し切ってから言え。

156 :nobodyさん:04/12/08 23:46:15 ID:???
海外では既にPHPへの移行が進んでるけどな
ていうかCGIが使えない鯖が増えてる
日本だけだねPerlに固執してるのは

157 :nobodyさん:04/12/09 01:09:16 ID:???
つまり、PHPへの移行が進んでるのは海外だけで、日本ではPHPは弱小、だから語る価値はない、ってことだね?

158 :nobodyさん:04/12/09 01:10:29 ID:???
日本でのPHPの不人気さは、本家のマルチバイト対応の軽視によるところが大きいと思うんだよね。

159 :nobodyさん:04/12/09 03:07:42 ID:???
海外が移行してるって言ってもPerlもJavaも最初そんなこと言ってたんだけどな

160 :nobodyさん:04/12/09 04:40:51 ID:???
現実的な話として、Javaは海外の普及度に追随して国内の普及度は上がったけど、PHPにはその兆候が見えない。
どうなの?

161 :nobodyさん:04/12/09 13:34:39 ID:???
時代錯誤なクライアントがcgiを強要する限り鯖屋もソース書きも儲かるさ

162 :nobodyさん:04/12/15 05:22:06 ID:???
海外で移行したからって日本が移行する必要性はないよね
特に「海外」ってどういうアンケートなんだろう

>>161
時代錯誤してないクライアントは何を強要するんだい?
現実路線としてCGIは十分ありえると思うけど

163 :nobodyさん:04/12/20 03:38:14 ID:???
ttp://www.itmedia.co.jp/enterprise/articles/0412/17/news007.html

PHPに複数の深刻な脆弱性、最新版へのアップグレードを

うp!うp汁!

164 :nobodyさん:04/12/20 09:29:15 ID:???
4.3.10にうぷ

165 :nobodyさん:04/12/20 13:55:25 ID:???
うpするの面倒だな
また再コンパイルしないといけないなんて・・・

166 :nobodyさん:04/12/23 04:22:52 ID:???
>>163
apt-get update で入らないのこれ?

167 :nobodyさん:04/12/23 12:36:27 ID:???
phpって普通apt-getで入っても自分でコンパイルして入れないか?
configureのオプションが使い方によって全然代わってくるし。

168 :nobodyさん:04/12/24 06:13:51 ID:???
phpごときでapt-get使う奴いたのね

169 :nobodyさん:04/12/24 07:15:44 ID:???
自分が触るサーバー群は、なるべく自分でconfigureしたほうがいいね。

170 :nobodyさん:05/01/26 19:34:45 ID:???
fixも5.0.3で止まってるみたいね。
そろそろ入れてみるか。

171 :nobodyさん:05/01/27 00:41:44 ID:???
もうPHP自体いいだろ。

172 :nobodyさん:05/01/27 09:44:29 ID:???
>>171
これからはどの言語がいい?

173 :nobodyさん:05/01/28 22:44:12 ID:???
perl

174 :nobodyさん:05/01/29 22:40:12 ID:???
またまたご冗談をw

175 :nobodyさん:05/01/31 01:49:34 ID:???
俺もPerlでいいと思うな

個人的にはサーバ管理もPerlの方が楽だしね
mod_perlもすぐできるし

176 :nobodyさん:05/02/03 03:02:53 ID:bOooCN0T
Perl5

177 :nobodyさん:05/02/03 15:22:27 ID:???
正直あんまりかわっとらんがな・・・。

178 :nobodyさん:05/02/03 20:14:31 ID:???
どっちでもかわらんのか・・・・
じゃあ、理不尽な仕様変更に泣かされることの少ないPerlのほうがいいってことだな。

179 :nobodyさん:05/02/04 23:48:48 ID:???
ぶっちゃけPerl6待ち

180 :nobodyさん:05/02/05 02:40:10 ID:???
またまたご冗談をw

181 :nobodyさん:05/02/05 17:56:47 ID:???
しかしいつまでたってもPHP5は
つ か い も の に な り ま せ ん ね wwwwwwwwwwww

182 :nobodyさん:05/02/05 20:35:20 ID:???
>>181
具体的根拠は?

183 :nobodyさん:05/02/06 00:26:46 ID:???
まあやたらに仕様変更して欲しくないってのはある

184 :nobodyさん:05/02/14 05:23:01 ID:???
>>183がいうように仕様変更は嫌だね
けど再makeしないでも環境いじれるように
CPANみたいなの欲しいね

具体的根拠を聞くということは使えるということか
ん〜Perl5.8の方がまだましだな。

おいらもPerl6待ちだけど。

185 :nobodyさん:05/02/14 09:39:22 ID:???
PHPはx.2.5ぐらいまでは使いたくない。
仕様はコロコロ変わるしセキュリティホールはポロポロ見つかるし。

186 :nobodyさん:05/02/14 11:18:51 ID:???
でも今度の PHP5 は今までより安定してるね

187 :nobodyさん:05/02/14 21:57:39 ID:???
PHP4.0xと4.3xでも全然違うしね。

188 :nobodyさん:05/02/14 22:41:26 ID:???
PHP5のclass関係は4と変わりすぎ

189 :nobodyさん:05/02/15 10:27:27 ID:???
それが 5 の目的だから。

190 :nobodyさん:05/02/15 17:33:05 ID:???
たいして変わってないと思うのは自分だけか

191 :nobodyさん:05/02/15 19:40:37 ID:???
>>190
同感。妥当な変更だし。

5.0.1 になって本当に安定した。
本家では 5.1 の話になってるくらいだし。
PHP5 が不安定、はデマだと思う。

192 :nobodyさん:05/02/15 23:14:29 ID:???
PEARだかPECLだか知らんが、ライブラリの仕様は安定してるの?
ライブラリの動きは安定してるの?

193 :nobodyさん:05/02/16 22:17:30 ID:???
安定してる/してない、というより未対応だろ。

194 :nobodyさん:05/02/17 09:23:19 ID:???
とはいえ順次対応していく、と発表されている

195 :nobodyさん:05/02/17 09:31:48 ID:???
じゃあまだ使いものにならんな

196 :nobodyさん:05/02/17 11:37:19 ID:???
PHP5、バリバリ使ってます。
社内の JSP 厨も PHP5 でようやくマシになったと
ぶつぶつ言いつつも使ってるね。

197 :nobodyさん:05/02/19 00:25:19 ID:???
安定してるしてないはお前等みたいなど素人じゃなくて
仕事としてやっている人間の意見なの。OK?

198 :nobodyさん:05/02/19 06:50:29 ID:???
Zendの方針自体が安定してないからダメダメ。

199 :nobodyさん:05/02/19 13:12:50 ID:???
>>197
不安定な部分はどこか言える?

200 :nobodyさん:05/02/19 20:09:07 ID:???
>>198
ソースは

201 :nobodyさん:05/02/19 20:23:29 ID:???
>>200
ttp://x51.org/x/05/02/1048.php
ここかな?
何を信じていいやら。

202 :nobodyさん:05/02/19 20:44:43 ID:???
PHP5 が不安定というデマは JSP 厨の工作?

203 :nobodyさん:05/02/19 21:07:19 ID:???
いや、PHP5がじゃなく、PHPが。
PHP4からPHP5で大きくかわったし、PHP5からPHP6でまた大きくかわらないとはいえない
PHP4もPHP4の中で大きくかわったし、PHP5もPHP5の中で大きくかわらないとはいえない

という話をしようと思ってたんだけど、基本的なライブラリさえPHP5にちゃんと対応してないなら、不安定以前の話だから、デマといえばデマだな。
言語はかろうじて安定したけど、ライブラリは安定どころか、完成すらしてない。

204 :nobodyさん:05/02/19 23:14:45 ID:???
>>203
君、PHP 使ったことないでしょ。
それに、他の言語のことも詳しくないでしょ。

205 :nobodyさん:05/02/19 23:48:25 ID:???
4から5で大きく変わったか!?
まじでPHPのこと何も知らないだろ。
ttp://www.php.net/manual/ja/faq.migration5.php
Javaもどきなオブジェクト指向だから
既存アプリの移植が面倒なだけで困る低脳はいないだろ。
なんなら互換モードでそのまま動くし。

Perlの4から5、Javaも1.1と1.3、1.4、
VBも.Netへの移行なんかに比べれば
言語仕様の変更は無いに等しいよ。

「基本的なライブラリ」ってPEARのこと言ってる?氏んどけ。

206 :nobodyさん:05/02/20 02:52:18 ID:???
ま、とりあえずPHP4から5ではPEARが動かなくなる程度の変更しかないな。

207 :nobodyさん:05/02/20 02:58:29 ID:???
Javaでは古いコードの動きが変わるような言語仕様の変更はないが。

208 :nobodyさん:05/02/20 02:59:49 ID:???
無いに等しい言語仕様の変更で動かなくなるほど、PHPのコードは神経質なんだね。

209 :nobodyさん:05/02/20 04:17:03 ID:???
PHPの言語仕様の変更が無いに等しいって言いきれるなんて
よほど幸せな環境にいるんだな。

210 :nobodyさん:05/02/20 14:14:27 ID:???
PHP 知らん奴が憶測で口を出すなよ。
PEAR は class 使っているから動かないんだよ。

それに Java で動きが変わらないって?
Hello, world レベルのこと言ってるの?
ttp://java.sun.com/j2se/1.4/ja/compatibility.html#incompatibilities1.4

211 :nobodyさん:05/02/20 17:29:17 ID:???
PHPは、クラス使ってれば動かなくなるんだよね。
特定APIの仕様が変わったというだけのJavaとはレベルが違うよ。
PHPの場合、API的位置付けだったPEAR自体が動かなくなってしまうんだからね。

なんか、PHPの人は必死だな。

212 :nobodyさん:05/02/20 17:57:45 ID:???
つーか4.0系と4.2以上でかなり違うよね。
マジ使えねぇ。

213 :nobodyさん:05/02/20 20:12:29 ID:???
3系から4系、4.0から4.1、4.1から4.2の移行を試みたことがない人なんだろうなぁ。

214 :nobodyさん:05/02/20 22:02:56 ID:???
>>211
PEAR が API 的位置付け!?はぁ?

それにクラスも機械的変換で動くんですけど。
Pukiwiki とか 4 から 5 対応したアプリのことを知らないの?

>>212-213
具体的にはどこか言える?
まさか global_register じゃないよね?


215 :nobodyさん:05/02/20 22:31:37 ID:???
>>214
PEARは標準クラスライブラリという触れ込みだったはずだが。

global_registerは影響のない変更ということにしたいわけですね。
使ってるやつが悪いと。ふーん。
4.2.2から、Content-type指定したときの挙動が変わった。
4.3.0から=演算子の挙動が変わったしね。

なんか、必死ですね。

216 :nobodyさん:05/02/20 23:39:53 ID:???
>>215
いいえ。CPAN 同様、拡張ライブラリです。
ttp://pear.php.net/manual/en/introduction.php
PEAR is short for "PHP Extension and Application Repository"

global_register の問題は PHP3 の時から言われていたことです。一体何年前の話ですか?
使っている奴が悪くないとでも?それに問題を理解しているなら extract(); と書くだけです。

Content-type は php.ini のデフォルトの設定が変っただけでしょう?
= 演算子が === のことを言っているのであれば
まともなコーディングしていれば何の影響もないはずですが?
少なくとも XOOPS、SquirrelMail, phpMyAdmin は PHP4.1.x 時代の
古いバージョンを PHP4.3.x に上げてもそのまま動きますが。
実際問題として >>215 の指摘した内容で変更しないといけないアプリって何かありましたか。
例えば sf.net に挙がっているような奴で。

言語のバージョンアップで仕様変更があるのは当然です。
>>205 にも書きましたが、Perl 4→5、Java1.1,1.3,1.4,VB→VB.NET に
比べれば PHP4 から 5 への変更はないに等しい、と言っているんですが。

PHP5 のクラスは機械的変換でそのまま動くのに何か問題でもあったの?
それに PHP4 互換モードまで用意されているのですが。

217 :nobodyさん:05/02/21 00:10:06 ID:???
>>216
> Content-type は php.ini のデフォルトの設定が変っただけでしょう?

Content-typeを指定するとエンコーディングの変換が効かなくなったバージョンがある。

ま、古いコードが動かなくなった変更点はそれを使ってるやつが悪いってことにすれば、言語仕様の変更はないに等しいといえることはわかった。
なかなか都合のいい論理展開だな。勉強になったよ。

218 :nobodyさん:05/02/21 00:13:08 ID:???
global_registerの設定が有効になってるのが前提の情報が広まってた状況を無視して、「使ってたやつが悪い」ですか。
おめでたいやつですね。

219 :nobodyさん:05/02/21 00:15:06 ID:???
> 少なくとも XOOPS、SquirrelMail, phpMyAdmin は PHP4.1.x 時の
> 古いバージョンを PHP4.3.x に上げてもそのまま動きますが。

そんな例持ち出すなら、Java1.1時代のバイトコードでJ2SE5で動くソフトは普通にたくさんあるわけだが。

220 :nobodyさん:05/02/21 00:17:54 ID:???
で、PEARが動かなくなったことは問題ではないわけだな。
標準ライブラリ的なプロモーションしておきながら、お荷物になれば標準じゃないですよ、か。
ところで、標準クラスライブラリは何になるの?

221 :nobodyさん:05/02/21 00:21:53 ID:???
ここはどうしてもJava vs PHPに持って行きたいJava厨とPHP厨のすくつですね

222 :nobodyさん:05/02/21 00:33:52 ID:???
いや、PHPの仕様変更はたいしたことないといいたいだけ。

223 :nobodyさん:05/02/21 00:35:04 ID:???
推奨されないコーディングをしてPHPの仕様変更にはまるのは、そんなコーディングするのが悪いと。
PEARは拡張ライブラリだから、PHPの仕様変更とは関係ない、と。

224 :nobodyさん:05/02/21 02:14:03 ID:???
俺は PHP 使いでもないし PEAR も使ったことがないのでよくわからんが、
Perl が 5.6 から 5.8 になったら CPAN のモジュールが動かなくなった、
みたいなことを想像すると「それはまずいんじゃない?」と思うな…

225 :nobodyさん:05/02/21 02:14:34 ID:???
>いいえ。CPAN 同様、拡張ライブラリです。
おいおい、一緒にすんなって。
規模がちげーっつーの。

226 :nobodyさん:05/02/21 02:29:08 ID:???
>>224
Perl4→Perl5なら動かなくてもかまわないんじゃないの?といいたいのではないかと。

227 :nobodyさん:05/02/21 09:12:58 ID:???
>>217
それはバグであって仕様変更ではないよね?
また、そのバグは何日で修正されましたか?
>>218
今でも global_register ON がいいの?
あと、普通程度の頭があれば global_register の危険性はすごに分かるよね?
PHP3 の時から危険性が指摘されていたんだよ?何年前の話?
>>219
この例は >>213 の嘘を指摘するためです。
>>220
PEAR のページを見ろよ。>>216 のリンク先とかさ。
標準ライブラリは
ttp://jp.php.net/manual/ja/
でコンパイル・オプションで選ぶだけで最初から組み込まれている奴だよ。
PEAR を使わない/知らないお前が何を問題にしているの?
>>224
Perl4 と Perl5 は?Perl5 と Perl6 は?
ここでの話は PHP4 と PHP5 の話だよ?
>>225
標準か拡張かの話であって規模の話ではないよね?

228 :nobodyさん:05/02/21 09:28:45 ID:???
>>227
すご→すぐ

元々の話は PHP5 はバギーか?だったよね。
でもそれがバギーじゃないことになったので
言語の仕様変更の話になったよね。

バージョンアップして言語使用の変更がなかった言語って何よ?

229 :nobodyさん:05/02/21 09:58:47 ID:???
PHP4 と PHP5 の非互換部分は OOP だけど、
言語使用が変わったと騒いでいる奴は
PHP4 のままのなんちゃって OOP がよかったの?

230 :nobodyさん:05/02/21 15:32:40 ID:???
>>227
> それはバグであって仕様変更ではないよね?

仕様変更。
日本側からの働きかけで、そのあとtext/*のときはエンコードの指定が効くようになった。

231 :nobodyさん:05/02/21 15:33:36 ID:???
小泉タンが頑張っていたね

232 :nobodyさん:05/02/21 15:35:00 ID:???
あぁ、PEARは、おまけでついてくる標準ではないライブラリってことなのね。
PHP4あたりから標準でついてくるから、てっきり標準ライブラリなのかと思ったよ。

233 :nobodyさん:05/02/21 15:36:53 ID:???
>>229
論理の飛躍ですね。

234 :230:05/02/21 15:45:46 ID:???
ちなみに、content-typeの仕様変更は4.2.2からで、4.2.1で見つかったセキュリティーホールに対策するためのリリース。
そのあとの4.2.3でも日本語関係バグバグ。
で、4.3.0からは=演算子の挙動が変わっている。
つまり、4.2.1のセキュリティーホールを挙動を変えずにふさぐバージョンはリリースされなかったってことだ。

PHPの仕様変更の不安定さというのは、そういうこと。

235 :nobodyさん:05/02/21 15:55:28 ID:???
> 今でも global_register ON がいいの?

そんなこと言ってないだろ。
ってか、global_registersにsがいることくらい、いい加減覚えろ。

236 :nobodyさん:05/02/21 17:37:00 ID:???
>>233-235
で、PHP5 が不安定な根拠は?


237 :224:05/02/21 18:51:18 ID:???
>>226-227
なるほど、確かにそうですね。
Perl4 の時には CPAN なんてなかった (で合ってる?) し、
Perl6 になったら Perl5 との互換性はすっぱり無くなるっぽいし、同じか。
困るってことには変わらないですけど…

238 :nobodyさん:05/02/21 19:55:33 ID:???
>>234
どんな言語でもバグや仕様変更あるので
細かな例を出しても何の意味もないです。
# 例えば Java であれば j-h でセキュリティの未修正や仕様変更で
# 何度も高木氏がポストしたことは古参 Java ユーザなら周知の通り。

それに、過去の例から PHP5.x が不安定である、
という論は無理です。

>>237
Perl4 中盤あたり?から CPAN ありましたよ。


239 :nobodyさん:05/02/21 22:24:16 ID:???
>>238
バグや仕様変更はあるが、セキュリティーパッチで仕様が変わることは、他の処理系では少ない。
というか、普通はない。

そういう過去の例があるから、PHP5も信用できない。
PHPが信用できないのは、セキュリティーパッチやバグフィックスで他の仕様が変わってきたから。
で、その仕様変更のポリシーが変わったという話は聞かない。

240 :nobodyさん:05/02/22 09:31:43 ID:???
>>239
その「仕様が変わったセキュリティーパッチ」で動かなくなった有名なアプリって何?

241 :nobodyさん:05/02/22 11:34:32 ID:???
>>234
それで動かなくなった有名なアプリって何?

242 :nobodyさん:05/02/22 12:21:21 ID:???
>>240
そもそも有名なアプリ自体が少ない

243 :nobodyさん:05/02/22 12:56:11 ID:???
>>242
sf.net には PHP アプリが 10430 くらいあるし、
ここのダウンロード数の上位 100 とかでどう?
ttp://sourceforge.net/softwaremap/trove_list.php?form_cat=183


244 :nobodyさん:05/02/22 13:02:59 ID:???
>>242
Google でそのアプリ名を検索して 5000 件以上あるとか。

245 :nobodyさん:05/02/22 18:19:49 ID:???
>>240
なんで、有名アプリである必要があるのかわからんが、EZWeb対応のアプリは動かなくなったはずだ。

ただ、この場合、問題なのは、セキュリティーパッチで他の仕様を変えるというそれ自体がセキュリティーホールであるということだ。

246 :nobodyさん:05/02/22 18:28:32 ID:???
>>245
捏造情報じゃないことの証明がほしいです。ソースありますか。

247 :nobodyさん:05/02/22 18:40:41 ID:???
>>246
は?
EZWeb用アプリでHDML吐くときtext/hdmlを出力するだろ。
そのとき日本語変換が効かなくなってたんだよ。

248 :nobodyさん:05/02/22 18:46:00 ID:???
>>245
私は煽りでも何でもなく後学のためにも有名じゃなくていいので
仕様変更によって動かなくなった具体例が知りたいです。

例えば Pukiwiki, XOOPS, phpBB, SquirrelMail, phpMyAdmin,
各種 blog は仕様変更で動かなくなったのですか?

あと、「この場合、問題なのは…」は >>239 とは違う話?
>>239 の仕様変更で動かなくなったものはありますか?

それと >>245 の詳しい話が知りたいです。

249 :nobodyさん:05/02/22 18:46:26 ID:???
いま気づいたが

>>216
> = 演算子が === のことを言っているのであれば

===は比較演算子だろ。
=演算子でオブジェクトがコピーされていたのが、参照が渡されるだけになったんだよ。

250 :nobodyさん:05/02/22 18:46:40 ID:???
>>247
EZWeb 系のアプリは全滅したんですか?

251 :nobodyさん:05/02/22 18:51:00 ID:???
>>248
だから、EZWeb対応の日本語変換が動かなくなってるはずだと。
で、なんで有名ソフトでなきゃいかんの?
こんだけ広範囲に影響がある変更が前触れもなしにあれば、PHPでモノ作ってるときに困るんだよ。
PHP用に作られたアプリ動かすだけのやつにはわからんだろうが。

252 :nobodyさん:05/02/22 18:51:58 ID:???
>>250
原理的にはそうだろ。HDML吐いてて日本語変換してるやつは。

253 :nobodyさん:05/02/22 19:05:38 ID:???
ウチで作ったEZWeb対応のやつは、それで動かなくなったなぁ。
セキュリティーホールってことでアップデートしたら、動かなくなってた。
で、結局元に戻した。
text/hdmlなら日本語変換が動くようになった4.3には他の変更があったから採用見送り。
それ以来、長く動かすシステムをPHPで組むのはやめた。

254 :nobodyさん:05/02/22 19:19:35 ID:???
別に自分は有名じゃなくていいですよ。
EZWeb 系が全滅だったら大問題なのに
ML やニュース、2ch の PHP スレで騒がれてないね。
解決策は PHP4.2 に戻すだけなんですか?

>>253
何で作ることにしたんですか?

255 :nobodyさん:05/02/22 19:20:47 ID:???
あと、この問題は
>>248
で書いた PHP アプリでは問題ないんですか?
この問題の詳細を URL でもいいので教えてくれないですか。

256 :nobodyさん:05/02/22 20:28:34 ID:???
>>254
> ML やニュース、2ch の PHP スレで騒がれてないね。

MLを見てないのか?

> 解決策は PHP4.2 に戻すだけなんですか?

コードを変えずに解決するには、セキュリティーホールの影響に注意しつつPHP4.2.1に戻すしかなかった。
設定でどうこうできるものではない。

257 :nobodyさん:05/02/22 21:02:02 ID:???
>>256
ML 見逃したかも。いつくらいの話題?あとキーワードとか。探してみる。

この問題が知りたい理由は >>248 で書いたアプリを参考に
4.3 でグループウェアもどきを作ったんです。それに影響あるか知りたい。
一体どういう問題なんですか?
不思議なのは >>248 のアプリは 4.3 で問題なく動いてますよね。
あと、4.3 で動いているサーバがほとんどですよね。
なぜ EZWeb 系以外の他の PHP アプリは全滅しないの?

258 :nobodyさん:05/02/22 22:13:13 ID:???
>>257
4.3で動いてるならいいんじゃねぇの?
4.3ではtext/*はちゃんと日本語変換効くようになったんだし。

> ML 見逃したかも。いつくらいの話題?

しらん。4.2.2が出た頃の話題。
HDML出力してる人はそれほど多くないし、祭りになってるわけではないが。

> 不思議なのは >>248 のアプリは 4.3 で問題なく動いてますよね。

すでに4.3が出てかなりの時間がたってて、なにを不思議がってるのやら。

> なぜ EZWeb 系以外の他の PHP アプリは全滅しないの?

お前、問題の意味全然わかってないだろ。

259 :nobodyさん:05/02/22 23:10:28 ID:???
>>258
EZWeb のことは指摘通り全然分かってないです。
というかこのスレに書かれた内容では分かりようがないです。
誰かこの件についてのページを紹介してくれませんか?
でも要は EZWeb の件は 2002 年の 4.2.2 の話で 4.2.3 以降では解決済?

1 からこのスレを読んだ限り、PHP の言語仕様が不安定さを示す具体例は
この EZWeb だけです。もしそうなら PHP は他の言語と比べると異常に安定しすぎです。
そんなことはないと思うので、そのほかに PHP の問題があるなら純粋に知りたいです。

PHP が不安定だと主張する人はどの言語を使っているかも知りたいです。

260 :nobodyさん:05/02/23 05:02:30 ID:???
>>259
は?
セキュリティホールがあったのが4.2.1
content-typeを出力するコード書いたら日本語変換されなくなるのが4.2.2
EZWeb用でHDML吐くときはtext/hdmlを出力する必要があるからEZWeb用は日本語変換されなくなる。
text/*なら日本語変換されるようになったのは4.2.3か4.3.0かわからんがそこらへん。
4.2.3には日本語関係のバグが多い。

言語仕様でいうなら、Javaは1.1と5.0で大幅に変わった以外はほとんど安定で、古いコードの動きがかわらないように注意が払われてるのだが。

で、問題にしてるのは、セキュリティーパッチで仕様が変わったってこと。
セキュリティーホールがみつかっても、バージョンアップできない。
そんな処理系、PHPくらいしかしらない。

261 :nobodyさん:05/02/23 06:06:03 ID:???
>>260
99.999999% の PHP アプリは問題なくバージョンアップできましたよね。
しかも text/hdml はコードを変更すれば 4.2.2 に上げることができたよね。

あと、セキュリティーホールが
ttp://www.php.net/release_4_2_2.php
のことならアップロード部分だけ 4.2.2 にして既存は 4.2.1 にもできましたよね。

PHP が問題であるという主張は 3 年前のその件だけですか?

> そんな処理系、PHPくらいしかしらない。

どんな処理系を知っているのでしょう?何と比べて?
少なくとも Java の 1.1.x 〜 1.3.x の x が 1 や 3 の時は
Applet に関してはそんなことばかりでしたが。
それを Sun が公開しない、問い合わせ先がないと高木氏がよく報告してましたが。
ttp://java-house.jp/ml/

ただ 1.4 から安定しましたね。PHP も 4.3.x で安定しました。
PHP も Java も過去の事例を元に現行を論じるのは単なる感情論ではないですか?


262 :nobodyさん:05/02/23 06:44:34 ID:???
>>260
Tiger との比較は意味がないと思います。
Tiger は C# などを意識して Generic や Autoboxing などの
今更?という改良を加え、マーケティング的な意味でのバージョンアップでしょう。
# 開発環境として PHP5 同様に楽になった Tiger は大歓迎ですが。

違う言語を単純にメジャーバージョンだけで比較するのは無意味ですが、
Perl 4→5 であれば関数の引数でもリファレンス渡しになったり ( jcode とか )、
VB と VB.NET は半分くらい書き直しましたし、
Java 1.3 →1.4 に関しては
ttp://java.sun.com/j2se/1.4/ja/compatibility.html
とか、PEAR のように JavaBeans/EJB/JBoss などを使っていた場合、
1.3 から 1.4 の移行は PEAR の移行より遥かに大変じゃないですか?
そのため 1.4 に移行できない 1.3 のプロジェクトって結構ありますよね?

私は以上の比較で PHP4→5 は「面倒」だが他の言語より「難しくない」と思います。
PHP5 の OOP は単純な機械的な変更ですから awk/sed で半自動で変換できました。
PHP4.0.x 〜 PHP4.3.x は 99% 以上が動く互換性もありますよね。

PHP が他の言語に比べて言語仕様が不安定だったり、移行が難しいとは感じません。

ただ、私は COBOL や VC/C# には詳しくないのでその比較はできません。
# C# は .Net 2.0 が出たら移行に大変そうなので手を出していません。

263 :nobodyさん:05/02/23 10:08:22 ID:???
>>261
> Applet に関してはそんなことばかりでしたが。

言語仕様の話をしてるのではないのか?
で、Appletに関しては、Microsoftの実装がJavaの仕様から外れてたからだ。

264 :nobodyさん:05/02/23 10:13:20 ID:???
4.0.6でいきなりPostgreSQLがうまく動かなかったりしたなぁ・・・

なんか、PHPではうまく動く事例だけを扱って、うまく動かない事例は例外ってことにして、Javaではうまく動かない事例をとりあげてうまく動く事例は例外のようにしてるとしか思えないな。
4.3から=演算子みたいな、基本的なところの動きが変わってるのに

> PHP4.0.x 〜 PHP4.3.x は 99% 以上が動く互換性もありますよね。

とか、ようゆうわ、って感じだし。

265 :nobodyさん:05/02/23 10:16:47 ID:???
何でそんなに文章が長いのさ

266 :nobodyさん:05/02/23 10:25:27 ID:???
> # C# は .Net 2.0 が出たら移行に大変そうなので手を出していません。

それと同じ理由で、PHP5はPHP5.1が出たら移行に大変そうなので手を出していません。

267 :nobodyさん:05/02/23 10:30:35 ID:???
261

> しかも text/hdml はコードを変更すれば 4.2.2 に上げることができたよね。

どんな変更するかわかってんのか?
そりゃ、コードさえ変更すればどんなアップグレードにも対応可能だ。
手間がかかりすぎるので4.2.1のままにした。

そういうアプリケーションの全体に影響するような仕様変更が、一番低いバージョンがあがったときになんの前触れもなく行われることを不安定だっていってる。
セキュリティーアップデートで仕様変更されることが信用できないと言ってる。

268 :nobodyさん:05/02/23 10:31:23 ID:???
>>263
ん?
>>260 氏も
| セキュリティーパッチで仕様が変わったってこと。
| セキュリティーホールがみつかっても、バージョンアップできない。
| そんな処理系、PHPくらいしかしらない。
であって言語仕様じゃないよね?
なのでセキュリティーパッチ云々の Java の例を出しただけです。

それと言語仕様の話って出てないと思うけど言語仕様の話って何?PHP5 の OOP の話?

>>264
| Javaではうまく動かない事例をとりあげてうまく動く事例は例外のようにしてるとしか思えないな。
それは >>260 などの主張も同じことだよね。

なので細かな事例を言い合っても仕方ないですね。
Java は言語仕様が大きい分、非互換やバグやセキュリティーホールは PHP より多いし。
自分は Java がメインだし、PHP も使う案件が増えてきたので
客観的な PHP の言語仕様の話をしたいです。なので具体例があれば挙げてください。

| > PHP4.0.x 〜 PHP4.3.x は 99% 以上が動く互換性もありますよね。
| とか、ようゆうわ、って感じだし。

この 99% が間違いであるなら、その訂正は動かない例をいくつか出すだけで済みますよね。
具体例を希望します。そうでなければただの煽りです。

>>265
ですね。今は新規開発ではなく保守の仕事が多いので退屈なので現実逃避中。

269 :nobodyさん:05/02/23 10:45:01 ID:???
>>267
どんな変更が必要かは貴君のソースを見なければ具体的にはなんとも言えないのだけど、
一般論で言えば全ファイルが一番最初に共通の処理を実行する仕組みなら簡単だったよね?

「前触れもなく」に関しては本家 php-dev でも議論になってたし、
小泉さんが日本の php-dev でもこの問題はリリース前に流してたよね?

あと、その仕様変更は 99.999999% の PHP アプリには問題ないよね。
セキュリティアップデートに限らず、どんなマイナーなバージョンアップでも
100% 完全互換を保証する言語はないよね?
それに、PHP の問題が 4.2.2 だけを指しているなら
Java/Perl/VB に比べると遥かに信用できるのですが。

また、その仕様変更が嫌なら 4.2.2 の PHP のソースに
「十数行」のパッチで互換が確保できたと記憶してるし。

270 :nobodyさん:05/02/23 10:48:02 ID:???
>>266
5.0.x → 5.1 の変更点の何を問題にしている?具体的に。根拠レスの煽り?


271 :nobodyさん:05/02/23 11:10:57 ID:???
267 氏が 99.999999% 大丈夫な仕様変更にはまってしまったのはご愁傷様です。

そして 3 年前に解決済みのその一点だけにおいて現在の PHP も信用できないと
評価することも尊重いたします。

でも、もうそのネタはループしてるし飽きたので、
「この言語仕様が PHP は糞」という新ネタをください。


272 :nobodyさん:05/02/23 11:36:24 ID:???
> 99.999999% 大丈夫な仕様変更

これは、日本語対応HDMLのサイトが0.000001%しかなかったってこと?
ま、これこそ根拠レスの煽りだな。

で、=演算子の仕様変更に関してはスルーしてるんだな。

273 :nobodyさん:05/02/23 11:39:53 ID:???
しかし、PHPの仕様変更の考え方をうまく反映してるよなぁ。
自分のまわりの99.999999%が大丈夫ならいいだろ、みたいな。
日本語使ってるやつなんか自分のまわりに0.000001%もいないから関係ないだろ、みたいなね。

274 :nobodyさん:05/02/23 11:41:54 ID:???
あと、結果論で、こういうコーディングしてれば大丈夫だったはずだから、そういうコーディングしてるのが悪いってね。
結果論ならなんだっていえるな。

275 :nobodyさん:05/02/23 11:52:42 ID:???
>>272
EZWeb 以外の実害はなかったからね。
煽れば必死になって他の具体例を挙げてくれるかと思って。
なので数字はお好きな値をどうぞ。

= 演算子で実害が出た実例の件はどうなりましたか?

>>273
269 で書いたけれど 100% 互換を保証している言語はありませんよね。
それついてはどう思いますか?

>>274
結果論の話をしたつもりも、するつもりもありません。

ただ、3 年前にこうだったから、という結果論に
終始していて建設的な話ができないのは残念です。


276 :nobodyさん:05/02/23 11:56:11 ID:???
>>273
EZWeb 業界における PHP の普及率でどうなの?
それによって数値が算出できると思うけど。

277 :nobodyさん:05/02/23 11:58:56 ID:???
>>272
世界的に見た場合の EZWeb だとそれくらいじゃない?
つーか、なんで糞 PHP を使っといて文句言ってるの?自己責任じゃない?
自分の技術力のなさを PHP のせいにしているだけだろ。

278 :nobodyさん:05/02/23 15:30:39 ID:???
>>267
「前触れ」はML以外にもRCで出てただろ

279 :nobodyさん:05/02/23 16:26:51 ID:???
>>267
「手間がかかりすぎるので4.2.1のままにした。」という
三流プログラマー自慢の意図はなんですか?一体どんな手間が掛かるの?

280 :nobodyさん:05/02/23 23:27:06 ID:???
俺今PHPを使った仕事をしてるけど、ちょっとバージョン返ると
すぐ挙動が不審になる。駄目だPHP超使えねぇ。

281 :nobodyさん:05/02/23 23:43:33 ID:???
頭のおかしな人には気をつけましょう
ttp://info.2ch.net/before.html

282 :nobodyさん:05/02/24 05:25:22 ID:???
>>275
なんでわざわざ実害ださなきゃいけないんだよ。
4.3で=演算子の挙動が変わってるから、バージョンアップすらしない。
動いてるシステムで、実害が出る可能性が高いバージョンアップするわきゃないだろ。

283 :nobodyさん:05/02/24 09:14:26 ID:???
スゲェ
今度は試しもせずに妄想で責めてきたよ

引き篭もってないで外の世界を見れば
下の中以上のプログラマのプログラムなら動くことが分かるのに
まぁ、下の下、頭のおかしなプログラマには無理なわけだが

だから100%完全保証を主張してるのか

284 :nobodyさん:05/02/24 11:53:21 ID:???
>>282
4日前の >>215 も具体例も試しもせずに=演算子が,と書いていたの!?
いったいそれで何の話がしたいの or できるの?
global_registersやezの件とか頭悪いなぁ,と思ってたけど
頭が悪いんじゃなくて頭がおかしいんですね.



285 :nobodyさん:05/02/24 12:59:45 ID:???
>>284
頭「も」悪いと思う

286 :nobodyさん:05/02/24 13:24:33 ID:???
PHPでの環境なんてまだほったて小屋みたいなもんだから、
具体例とか、実害とか、実例とか99.9パーセントとか言うな。
適当に最適なコード書いとけ。ハゲ!


287 :nobodyさん:05/02/24 14:09:13 ID:???
>>284
具体例って、仕様が変わってて明らかに影響があるんだから、移行しなかっただけ。
なんで、実害あるのわかってて試さにゃならんのだ?

288 :nobodyさん:05/02/24 14:36:09 ID:???
そろそろ結論お願いします。

289 :nobodyさん:05/02/24 15:38:35 ID:???
>>288

286-287 によると
具体例とか、実害とか、実例とかないけど PHP はダメだそうです。
あと、バージョン上がっても 99.9 パーセントが何の問題もなく動くけど PHP はダメだそうです。

290 :nobodyさん:05/02/24 16:03:02 ID:???
PHPがダメとは言ってないだろ?
(try{}catch{}も5でやっとこさできるようになったようなヘタレ言語だがな!)
おまいが「PHPってダメなの?」思ってるだけなんじゃなくて?
このインポ!

291 :nobodyさん:05/02/24 16:46:08 ID:???
>>290
| PHPがダメとは言ってないだろ?

そうだったんですか。じゃ、どういう主張だったのですか?

|(try{}catch{}も5でやっとこさできるようになったようなヘタレ言語だがな!)

Autoboxing や Generic も 5 でやっとこさできるようになったようなヘタレ言語だがな!
というようなことを言うことに何か意味がありますか?

善いことをするのに遅いと責める気はありません。
善いことをしないのであれば催促したいですが。

| おまいが「PHPってダメなの?」思ってるだけなんじゃなくて?

そうです。C/Java/VB/Perl の比較において PHP が特別にダメとは思えません。
ダメな点はありますが、それはどの言語でも同じことです。

| このインポ!

頭のおかしな人には気をつけましょう
ttp://info.2ch.net/before.html
| 根拠もなく、他人を卑下したり、差別したりする人、自分で自分を褒める人


292 :nobodyさん:05/02/24 17:03:02 ID:???
なんだよなんだよ、言葉尻ばかりつかまえて。
いじめてるつもりはないが、2ちゃんなんだし罵り合い上等でしょ。
別におまいの自尊心=PHPってわけでもねーだろ。
おまいも99.9パーセント動くけど(もじもじ・・・)とかさあ、うざいよ、
なんの分母の99.9だよ。たいした評価じゃあなかろうに。
それにしてもPHPは事実人気もあることだし、
より良いオブジェクト指向、フレームワークの充実、と
良いところはたくさんあるんだから、がんばってほしいと思うよ。
RubyやJAVAを参考にしながらOOを整理していってほしいし、
かつ、ライトウェイトっつー身軽なところを伸ばしていって欲しい。
ってかたっちまった。当たり前なことを。野暮ったいね。


293 :nobodyさん:05/02/24 17:31:47 ID:???
99.9% は地球上の全 PHP アプリのことね。
「もじもじうぜぇよ」ともじもじしないで不明なことは聞くように。

あと、もし 99.9% に突っ込みたいなら
「99.9% は言い過ぎだろ、デブ」だけの根拠なしではなく、
「○○で××だから98.7%だろ」という論理的反証でよろしく。

後半はハゲ同。建設的でいいね。

一番好きな言語は Ruby。素晴らしい OOP だ。
一番嫌いなのは一番使っているせいか Java。
203 からのを読むとこんな程度で騒ぐなよ、という感じ。


294 :nobodyさん:05/02/24 19:27:53 ID:???
>>293
ワロス。
やっぱRubyはいいよな。
オタとか言われてるけど、んなこたぁーないぞ。
あれに学んだ人のPHPのコードは素敵そうだもの。

295 :nobodyさん:05/02/24 19:54:41 ID:???
Ruby も Rite で RAA 全滅するけど
妥当な変更による結果なので文句を言う気はない。
PHP4 → 5 で PEAR が動かなくなるのも同様。

PHP4 の OOP は Perl 同様ありえない。
まぁ、非 OOP の互換性を保ちつつ
OOP の皮をかぶせるためには仕方ないのだが。

PHP5 の OOP 化は Java を手本としているので冗長で退屈。
Ruby のようにスッキリ書けると嬉しいのに。
あと ; が不要になるともっと嬉しい。


296 :nobodyさん:05/02/24 23:29:31 ID:???
つーかお前等なんでそんなにPHPに固執してんの?
まるでPHPしかできないみたいな必死さだな。
PHPしかできないんじゃプログラマとして将来期待薄だな。
せめてJavaとかPerlくらいは理解しとけよ。

297 :nobodyさん:05/02/25 02:43:01 ID:tNmKJfeD
おまえらはどれだけデザインパターンを理解して・・・

298 :nobodyさん:05/02/25 07:01:06 ID:s0E0f9v3
スレが立ってからもうじき3年だけど、3年で何が変わった?
perlやrubyのcgiはなくなったか?

299 :nobodyさん:05/02/25 10:16:04 ID:???
インターネッツできない場所にでも幽閉されてた人ですか

300 :nobodyさん:05/02/25 11:31:02 ID:???
>>298
3年前の餌に今頃釣られなくても

301 :nobodyさん:05/02/25 23:24:23 ID:???
PerlのCGIは少なくなったね。

302 :nobodyさん:05/02/25 23:50:06 ID:???
普通にまだ多いと思うが。少なくとも日本で"配布されている"WebアプリではまだPerlが一番多いだろうな。
使用されている物については同じかまだPHPの方が少ないぐらいかな?
海外だとPHPの方が抜いてるみたいだけど中国韓国ではASPだんとつ、他ではJSPやPHPって感じだったかな。

303 :nobodyさん:05/02/26 07:26:29 ID:???
わざわざCGIで動かさんだろ。

304 :nobodyさん:05/02/26 07:27:06 ID:???
中国韓国ではASPが無料で使えるからなw。

305 :nobodyさん:05/02/26 13:53:17 ID:???
まぁ、数値の取り扱いが仕様で決まってないPHPで、数値の計算をまともにやろうとするな、ってことだな。

306 :nobodyさん:05/02/27 00:19:27 ID:???
え?

307 :nobodyさん:05/02/27 22:37:14 ID:g0YeQIeP
PEARのPHP5対応率って低い?
先を見越してPHP5で何か作ろうと思うんだけど。

308 :nobodyさん:05/02/27 22:51:58 ID:???
開発が進歩してるのはaspと思うんだが・・・

309 :nobodyさん:05/02/28 10:52:08 ID:???
>>307
人気のある PEAR は大丈夫。
自分が何の PEAR を使うか確認してみては。

310 :nobodyさん:05/03/01 00:31:54 ID:???
>>309
レスサンクス
PEARが対応してるならOKだね。

311 :nobodyさん:05/03/01 00:37:16 ID:???
>>310
読み違えていると思われ。

312 :nobodyさん:05/03/02 01:31:22 ID:???
smartyは?

313 :nobodyさん:05/03/02 10:40:15 ID:???
PHP5 で問題なく使えるよ。PHP4.0.6 以降に対応。

314 :nobodyさん:05/03/03 20:19:42 ID:???
PHP5をインストールするとSQLiteも自動的にインストールされますか?

315 :nobodyさん:05/03/04 02:21:01 ID:???
試してみましょう。

316 :nobodyさん:05/03/04 04:04:31 ID:???
>>315
知ってるなら教えてよ。
いじわる。

317 :nobodyさん:05/03/10 00:20:17 ID:57S9mKWn
PHP5ってApache2にしか対応してないんだっけ?

318 :nobodyさん:05/03/10 09:45:08 ID:???
>>316
ttp://jp.php.net/ref.sqlite
>>317
ttp://jp.php.net/manual/ja/install.unix.apache2.php
>>319-
ttp://jp.php.net/manual/ja/

319 :nobodyさん:05/03/13 16:35:40 ID:???
>>318
とりあえずPHPは5になってもapache2では使うべきではないってことかな?

320 :nobodyさん:05/03/13 22:05:30 ID:???
318 のドキュメントを読んで
319 の質問をしてくる人に
何て書けば理解してくれるのだろうか

321 :nobodyさん:05/03/13 23:05:05 ID:???
>>320
世の中には差別用語や放送禁止用語と言った言葉が用意されていますので
必要なときは遠慮なく使ってみてください。

322 :nobodyさん:05/03/14 10:42:57 ID:???
319はピー

323 :nobodyさん:05/03/15 03:01:15 ID:???
>>320

>Unix上でもWindows上でも Apache 2.0.xとPHPの組合せを実運用環境で使用するべきではありません。
>「その理由については、 FAQエントリも参照して下さい。

324 :nobodyさん:05/03/15 09:29:25 ID:???
ttp://jp.php.net/manual/en/install.unix.apache2.php
> We do not recommend using a threaded MPM in production with Apache2. Use the prefork MPM instead, or use Apache1. For information on why, read the following FAQ entry


325 :nobodyさん:05/03/15 13:57:33 ID:???
>>323-324
日本語版は言葉足らずってことですね
Apache2でもPHPをprefork MPMでmakeすればOKってことでよろしいでしょうか。


326 :325:05/03/15 14:05:13 ID:???
prefork MPMでmakeするのはapache2のほうでした
っていうか普通にmakeすればpreforkになるんですね。

327 :nobodyさん:05/03/16 01:12:25 ID:???
落ち着け。よく読め。Google しろ。な。

328 :nobodyさん:05/03/16 12:37:39 ID:???
つまりPHP5はApache2でも普通に使えると

329 :nobodyさん:05/03/16 13:07:10 ID:???
windowsのローカルでは普通に使えてましたよ。
今はApache2+PHP4に切り替えてるけど。
なんかPHP5重大なバグが無かったっけ。

330 :nobodyさん:05/03/16 13:35:54 ID:???
5.0.3 には特に重大なバグはないと思うよ
近々バグ修正した安定版である 5.0.4 が出る
久しぶりのリリース

331 :nobodyさん:05/03/19 21:12:35 ID:???
PHP5.1マダー? (・∀・ )っ/凵⌒☆チンチン

332 :nobodyさん:2005/03/23(水) 02:44:30 ID:???
しかし、Zendのアホ開発者がとろっとろやってるから
ユーザーはマジ迷惑してる。
本屋にはPHP5本も充実してきてるっつーのに肝心のPHP5自体が
ぐだぐだだもんな。何とかしろよ糞Zend

333 :nobodyさん:2005/03/23(水) 14:26:14 ID:???
おまいが参加すれば何とかなるよ?

334 :332:2005/03/24(木) 17:18:25 ID:???
おれは天才だからな。なんとかなるだろう。きっと。

335 :nobodyさん:2005/03/24(木) 18:41:59 ID:???
PHP5が企業サイトで使われるようになるころにはPerl6登場。

336 :nobodyさん:2005/03/25(金) 00:42:21 ID:O1ekkWSV
  ,j;;;;;j,. ---一、 `  ―--‐、_ l;;;;;;
 {;;;;;;ゝ T辷iフ i    f'辷jァ  !i;;;;;   PHP1色の時代が来る・・・
  ヾ;;;ハ    ノ       .::!lリ;;r゙  そんなふうに考えていた時期が
   `Z;i   〈.,_..,.      ノ;;;;;;;;>  俺にもありました
   ,;ぇハ、 、_,.ー-、_',.    ,f゙: Y;;f
   ~''戈ヽ   `二´    r'´:::. `!

337 :nobodyさん:2005/03/28(月) 16:15:35 ID:AxvngZW7
なんでPHP5って盛り上がらないの?

338 :nobodyさん:2005/03/28(月) 16:52:23 ID:???
PHP4までやってきた香具師がJAVAに浮気中。
俺はPHP5に戻ってきたぜぇぇぇー。

339 :nobodyさん:2005/03/28(月) 21:45:04 ID:???
そしてPHPに戻るのは少数派。

340 :338:2005/03/28(月) 23:29:34 ID:???
ひさびさにWINDOWSでPHPの開発環境整えてて思ったんだけど、
PHP4とPHP5をサクサク切り換える方法ってなんかないの〜?

341 :nobodyさん:2005/03/29(火) 09:38:01 ID:???
別ポートで Apache を起動してる

342 :nobodyさん:2005/03/29(火) 10:16:59 ID:???
php5を案インストールする

343 :nobodyさん:2005/03/29(火) 12:37:13 ID:???
>>341
php.iniはどうしてる
俺はWindowsで再コンパイルがめんどいのでバイナリエディタでファイル名らしき所をph5.iniに無理やり変えてるけど

344 :nobodyさん:2005/03/29(火) 13:03:11 ID:???
コンパイルが面倒なら coLinux や VMWare とかは

345 :nobodyさん:2005/03/29(火) 13:24:53 ID:???
のーみそコネコネ

346 :343:2005/03/29(火) 13:51:19 ID:???
>>344
>>338=340がWindowsって書いてたので
今はPHP5のみにしてるけどね

347 :nobodyさん:2005/03/29(火) 13:52:37 ID:OQ4y9YMB
なぜPHP5スレは盛り上がりませんか?

348 :nobodyさん:2005/03/29(火) 14:35:48 ID:???
XAMPPでも使ってろ

349 :nobodyさん:2005/03/29(火) 16:13:56 ID:???
>>347
デンパがdでないからです。

350 :338=340:2005/03/29(火) 18:10:42 ID:???
みんな、トン。

結局、

php.ini(5のやつ)
pnp_bak4.ini
pear.ini(5で生成したやつ)
pear_bak4.ini

っていうように保存しておいて、
httpd.confはコメントアウトで簡単に4と5を
切り換えられるようにすたよ。

351 :nobodyさん:2005/03/30(水) 00:57:37 ID:???
つうかphp4ベースのソースをphp5のサーバーで使って不具合あった?
エラーが出るのはソースが古かったりphp.iniの設定が一致してないときぐらいでしょ?
逐次アップデートしながらソース書いてりゃ問題ないよ。

352 :nobodyさん:2005/03/30(水) 01:00:03 ID:???
$this がだめねなんねん。

353 :nobodyさん:2005/03/30(水) 01:42:16 ID:???
>>351
> ソースが古かったりphp.iniの設定が一致してないときぐらいでしょ?
> 逐次アップデートしながらソース書いてりゃ問題ないよ。

そういうのは、不具合というのだと思う。

354 :nobodyさん:2005/03/30(水) 11:15:43 ID:???
しかし今更4.1で変更になった部分とかを挙げられても困る罠

355 :nobodyさん:2005/03/30(水) 11:31:46 ID:???
PHPの「$this->」って文法的におかしいよな。
親クラスを表すのが「parent::」なら
カレントクラスを表すのは「this::」だと思うんだけどどうよ?

356 :nobodyさん:2005/03/30(水) 11:45:45 ID:???
いっそのこと「this.」にしよう

357 :nobodyさん:2005/03/30(水) 14:50:44 ID:???
>>355
オブジェクト指向をわかってない気配。

358 :nobodyさん:2005/03/30(水) 15:16:26 ID:???
>>355
自インスタンスを表す変数だから、文法的には「$this->」のほうが合ってる
自クラスを「this::」にするとなると「MyClass::」と書くのと一緒のことになる
親クラス「parent::」は「SuperClass::」とも書けるだろ?

359 :nobodyさん:2005/03/30(水) 21:03:13 ID:???
まともなレスで悪いんだけど$thisって失敗だったと思わん?
$this省略して$global->func()のほうが便利な気がする。

360 :nobodyさん:2005/03/30(水) 21:53:35 ID:???
ぜんぜんまともじゃない。
$global->pg_connectとか$global->mktimeとか、PHPは標準では関数ライブラリしかないのに、それにいちいち$thisをつけるのはめんどう。

361 :nobodyさん:2005/03/31(木) 09:33:34 ID:???
ruby ってどうだったっけ

362 :nobodyさん:皇紀2665/04/01(金) 08:50:11 ID:???
面倒だと思う奴は議論に参加する権利すらない

363 :nobodyさん:皇紀2665/04/01(金) 10:53:17 ID:???
PHPってJavaを真似てるんだからJavaもそんなんじゃないの?>$this

364 :343:皇紀2665/04/01(金) 11:23:38 ID:???
C++でも this-> だけど省略できる

365 :nobodyさん:皇紀2665/04/01(金) 12:31:13 ID:5oHi3yud
PHP5をどうしても使いたいんだけど対応してるレンタルサーバーってある?
できれば無料がいいけどなければ有料でもかまわないんだけど。

366 :nobodyさん:2005/04/02(土) 15:54:55 ID:O+IrCd/h
うーん、自力で探してみたけど
PHP5の使えるレンタルサーバーは皆無だね。

367 :nobodyさん:2005/04/03(日) 04:32:23 ID:???
なんで対応しないの?(´・ω・`)
xrea対応してよ

368 :nobodyさん:2005/04/03(日) 04:37:46 ID:???
既存スクリプトが動かなくなる危険をおしてまで採用するメリットがないから

369 :nobodyさん:2005/04/03(日) 12:19:21 ID:???
なるほど、他に被害が出る訳ね

370 :nobodyさん:2005/04/03(日) 14:42:11 ID:???
>>368
ん?既存のPHP4と互換性ないの?

371 :nobodyさん:2005/04/03(日) 14:50:42 ID:???
ないよ

372 :nobodyさん:2005/04/03(日) 19:18:42 ID:???
まじかよ。ツッカエネーな。>PHP5

373 :nobodyさん:2005/04/03(日) 19:56:00 ID:???
だから使われてない

374 :nobodyさん:2005/04/03(日) 20:52:09 ID:???
これはもう完璧にZendの責任だな。
使えないものをリリースするなっつーの。

375 :nobodyさん:2005/04/03(日) 21:10:40 ID:???
だからIBMがテコ入れをするわけだ。

376 :nobodyさん:2005/04/03(日) 23:08:23 ID:???
移植作業は至って簡単な置換作業で終わった

377 :nobodyさん:2005/04/04(月) 00:43:32 ID:???
ヘンなコーディングしてなきゃそのまま動くよ。

378 :nobodyさん:2005/04/04(月) 00:46:06 ID:???
自分の基準でへんなとかへんじゃないとかいったところでねぇ・・・。
PEARというライブラリまるごと怪しいんだし。

379 :nobodyさん:2005/04/04(月) 00:48:06 ID:???
ま、Zend自体も互換性について>>376-377みたいな甘い考えしてるんだろうな。

380 :nobodyさん:2005/04/04(月) 01:25:25 ID:???
PHP5スレも盛り上がらないわけだ。
もうPHPは終わったなw

381 :nobodyさん:2005/04/04(月) 01:34:17 ID:???
IBMが何をやってくれるかだな。

382 :nobodyさん:2005/04/04(月) 04:26:55 ID:???
きっとそのうち何とかしてくれるよ。
期待してるさPHP5♪

383 :nobodyさん:2005/04/04(月) 04:34:34 ID:???
>>367
XREAはPHP5が入っている鯖もある。

384 :nobodyさん:2005/04/04(月) 20:26:21 ID:???
ここでグダグダと書いてるバカどもは当然PHP5のソースアーカイブに入ってる
README.PHP4-TO-PHP5-THIN-CHANGES は読んでるよね?



385 :nobodyさん:2005/04/04(月) 21:43:54 ID:???
>>384
いちいちそんなもん読むわけねーだろ

PHP5はすげー簡単なんだよ
バカでもアホでもPHPは楽しいな♪ってのが売りなのさ
今はじめずにいつはじめるって言うんだ?あ"?
ボケッと見てるだけのやつは今すぐインスコ汁!
そしてPHP4使ってるやつに、まだそんなもん使ってんの〜、ぷ
っていってやれ。
明日から世界が変わること間違いなしだぞ!





しょぼーん

386 :nobodyさん:2005/04/04(月) 22:09:27 ID:???
>>384
で、それがPHP4とPHP5の互換性がないことのどういう解決になるの?
多い少ないの問題じゃないんだよ。

387 :nobodyさん:2005/04/04(月) 22:37:39 ID:???
てゆーかPHP5が世の中で使われてないのは
PHP4との互換性の問題じゃなくてまだ安定してないからでしょ?

388 :nobodyさん:2005/04/04(月) 23:14:00 ID:???
互換性がなくて魅力がなくて安定してないから。
・・・安定はそれなりにしてると思うが。
互換性さえあれば、魅力なくてもとりあえず移行できるのに、互換性を乗り越えて移行するには魅力がないことには。
人件費タダで信頼性求めない趣味ならすぐ移行できるんだろうけど。

389 :nobodyさん:2005/04/04(月) 23:50:32 ID:???
実際問題、PHP4用に書いたスクリプトがPHP5で動かなくて困ったことってないけどな。
それに、例外処理があるだけでも充分に魅力的だと思うよ。

390 :nobodyさん:2005/04/05(火) 00:02:52 ID:???
いくら待っても互換になりませんYO!

391 :nobodyさん:2005/04/05(火) 01:22:45 ID:???
互換互換ってプログラムに味覚や嗅覚は必要ねーんだよ!
三角で十分。三角の頂点はもちろんP・H・Pだ!
三角形ってのは三辺の長さが決まれば合同が保障される最も安定な図形なんだよ。
その安定の上に互換の5が付いたPHPはまさに無敵だろ?
これ以上待っていたら何もしないまま年だけとっちまうがおまいはそれでいいのか?
いや、おまえ自身もこのままでいいはずが無いと思っているはず
そう、貴様のためにPHP5があるんじゃないか!

392 :nobodyさん:2005/04/05(火) 03:58:51 ID:???
>>391
こういう人に未来を託せば、PHPの将来も明るいね。

393 :nobodyさん:2005/04/05(火) 04:00:17 ID:???
魅力がでてくることはないから互換性を頼りたいところだけど、いくら待っても互換になりませんYO!

394 :nobodyさん:2005/04/05(火) 10:38:02 ID:???
パフォーマンスが高いとか、なんらかのメリットがないとなかなかね
スクリプト言語だし例外処理だけでは差し替え理由にはならないよ

395 :nobodyさん:2005/04/05(火) 13:27:32 ID:???
具体的にどこが互換性無いのか言ってごらん。

396 :nobodyさん:2005/04/05(火) 13:56:20 ID:???
>>395
changeLogよめ

397 :nobodyさん:2005/04/05(火) 17:18:30 ID:???
>>395
PHP5 を試してもいない低脳アンチに構っても無駄

398 :nobodyさん:2005/04/05(火) 22:03:49 ID:???
で、PEARが使えないっていうのは?
PEARが使えなくなる程度に互換性がないっていうのは?
どうなの?

399 :nobodyさん:2005/04/06(水) 02:35:00 ID:???
ライトユーザーなら移行もまだ楽かもね

400 :nobodyさん:2005/04/06(水) 08:11:41 ID:???
PHP4も動くオプションをつけられれば移行も促進されるだろうに。

401 :nobodyさん:2005/04/06(水) 11:53:37 ID:???
>>398
どの PEAR ?

402 :nobodyさん:2005/04/06(水) 15:56:56 ID:???
指摘されたらアンチ扱いか(苦笑)
酷い妄信的な人が居るもんだね。
どんどん使いやすくなって欲しいってのが、本当のユーザーだと思うんだけど。

403 :nobodyさん:2005/04/06(水) 16:07:25 ID:???
>>400
あるよ

404 :nobodyさん:2005/04/06(水) 21:57:22 ID:???
このスレの伸びを見ればPHP5が(今のところ)
失敗に終わっているというのは紛れも無い事実だと分かるんだがね。

405 :nobodyさん:2005/04/07(木) 09:22:09 ID:???
別に失敗しているわけではないよ
PHP4と同等くらいではある
ただ、同等では人は動かない

406 :nobodyさん:2005/04/07(木) 10:06:34 ID:???
同等か?
PHP5 は PHP4 より高速だし、
OOP もまともになって超快適だけど。

407 :nobodyさん:2005/04/07(木) 10:59:46 ID:???
昔、MSXってあったじゃん。8bitCPUの。
あれの16bit版のMSX turboRって出たんだよね。
もちろんMSX turboRはMSX2+より高速だし、
MSX-DOS2が標準になって超快適だった。
でも、周りの進化はもっと速かったんだよね。
位置付けとしては、MSX2+と同等以下になってた。

PHPもそんな感じ。

408 :nobodyさん:2005/04/07(木) 11:17:00 ID:???
で、この場合PHP5よりも「進化の速い」のは何?
くだらんたとえ話はやめようぜ。

409 :nobodyさん:2005/04/07(木) 11:22:40 ID:???
PHP5って速度ではPHP4に劣るらしいな。
それでも俺はPHP5のOOを使いたいのだが、
国内のレンタルサーバーを見る限りPHP5が入ってるのは皆無。
現実問題としてPHP5は失敗なんだよ。

410 :nobodyさん:2005/04/07(木) 14:26:39 ID:???
>>409
PHP5 のリリース前は遅いと言われていたけど、
実際は PHP5 の方が速い。
日経とかでベンチマーク記事あるから見てみ。

あと、実際やってみ。
低スペック・マシンで動かすと体感も速い。

411 :nobodyさん:2005/04/07(木) 15:42:53 ID:???
なんか欧米に比べて日本のPHP利用者はPHP5に全然興味ナシみたいだな。
単にPHP底辺ユーザーにとってPHP5が手強すぎるだけか?

412 :nobodyさん:2005/04/07(木) 15:51:57 ID:???
移行すんの面倒臭いとみた

413 :nobodyさん:2005/04/07(木) 15:53:24 ID:???
Ruby が国内で普及しないのと同じ?
Perl や Java にしがみついているのかな。

414 :nobodyさん:2005/04/07(木) 15:56:28 ID:???
>>412
どこら辺がめんどいと思う?

1年前からPHP5のOOPが変わること知ってたし、
Perl同様、PHPの糞なOOPを使っていなかったので
ほとんどそのまんまPHP5で動いてるけど(300ファイル5万行)。
PEARのメールやSmartyも無変更で使えるし。

415 :nobodyさん:2005/04/07(木) 16:24:43 ID:???
PHP5のOOを活用するという意味を含めた上での移行は
実際面倒なんじゃないの。
サーブレットやStrutsのAPIとか、JAVAの例外処理とかインターフェイスを
理解してないとPHP5の本領は発揮できないじゃん。

416 :nobodyさん:2005/04/07(木) 16:41:31 ID:???
>>415
意味がわからん。
PHPなのに、なんでServletやらStrutsやらJavaの例外処理とかインターフェイスを理解する必要があるんだ?
JavaはJava、PHPはPHPだと思うぞ。

確かに大規模なもの作るならフレームワークとかあったほうがいいが、
それはPHPならではのフレームワークで良いと思うが?
StrutsやJavaの真似をするぐらいなら、素直にStrutsとJavaを使うだけじゃねぇ?

417 :nobodyさん:2005/04/07(木) 17:48:56 ID:???
PHP5が浸透する前にPHP6でるよ。

418 :nobodyさん:2005/04/07(木) 17:54:37 ID:???
Java と PHP を使う身としては
415 が言うように Java で便利だなーというものが
PHP5 で使えるようになって嬉しい。

まぁ、例外とかインターフェイスは Java に限らず
Ruby なんかでも持つものなので 416 はカッカせず
Java の部分を OO とかで読み替えればええんじゃない。

419 :nobodyさん:2005/04/07(木) 17:55:26 ID:???
PHP6 の目玉は何だろうね

420 :nobodyさん:2005/04/07(木) 18:40:40 ID:???
Parrotじゃね?

421 :nobodyさん:2005/04/07(木) 18:42:32 ID:???
PHP5も浸透していないこの状況でPHP6が出たらPHPは終了するな。

422 :nobodyさん:2005/04/07(木) 18:48:57 ID:???
>>420
ああ、そうだね。
Perl のライブラリが使えるようになるのはありがたいなぁ。

423 :nobodyさん:2005/04/07(木) 23:30:13 ID:???
というわけでPHPは終了って事でFA?

424 :nobodyさん:2005/04/08(金) 01:06:31 ID:???
うん。
いまさらOO言語になったことだけが売りのPHPは終了。
型なし言語のくせにJavaのようなOOだから、言語仕様としては全く魅力もないし。
だからといってライブラリが充実してるわけでもなく。

425 :nobodyさん:2005/04/08(金) 01:58:18 ID:???
全然関係ないけど、PerlとPHPでオブジェクト指向一生懸命勉強したけど、殆ど理解できなかった。
クラスの作り方や使い方はある程度は分かってたけど、巨大になってくるとそれぞれをどういう風に組み合わせればいいのかさっぱりだった。
いわゆるフレームワーク…?
最近ActionScript始めたら、オブジェクト指向ってものが少し分かってきた気がする。
Flashはオブジェクトとか目に見えてるから分かりやすいんかな?

426 :nobodyさん:2005/04/08(金) 02:01:27 ID:???
ああ、でも分かったって言ってもPHPやPerlに比べてActionScriptのOOPは全然使いづらいけど…。

427 :nobodyさん:2005/04/08(金) 07:07:38 ID:???
>>425
Lispやってみ、嫌でも身に付くかも。

428 :nobodyさん:2005/04/08(金) 09:33:46 ID:???
>>425
言語の問題じゃなくて作るものの種類の問題。
オブジェクト指向が向く分野と向かない分野がある。
Webアプリケーションではオブジェクト指向設計がほとんど必要ないから、PHPとかPerlでオブジェクト指向を勉強しても理解するのは難しいと思う。
オブジェクト指向の勉強にはブロック崩しとか簡単なゲーム作るのがいい。

429 :nobodyさん:2005/04/08(金) 09:53:59 ID:???
PHP4 と Perl の OO は学ばない方がいい。
PHP5 や Java, Ruby をどうぞ。

430 :nobodyさん:2005/04/09(土) 13:10:53 ID:???
とっととPHP5でPHP4とPHP5のソースが共存できるようなシステムを
提供しやがれ>Zend

431 :nobodyさん:2005/04/09(土) 13:12:09 ID:???
ちなみにPerlの場合Perl6と平行してParrotで動くPerl5を開発してる。
こういうユーザーへの配慮がまったくないんだよZendのアホは。

432 :nobodyさん:2005/04/09(土) 14:19:10 ID:???
突き詰めれば無駄を省くのが正しい
肥大化したものはゴミ遺産になりかねん
PHP5に対応出来ないユーザーは使うな
という事で良いでしょ

433 :nobodyさん:2005/04/09(土) 17:48:52 ID:???
>>430
ありますよ。マニュアル嫁。

434 :nobodyさん:2005/04/09(土) 23:34:57 ID:???
>>432
例えゴミ遺産であっても膨大な素人ユーザーのことを考えたら
なんかしらの対応をすべき。その対応を怠った為現在のような
PHP5リリースしてるのに誰も使ってないという状況になってる。

435 :nobodyさん:2005/04/10(日) 00:33:39 ID:???
>>434
遅かれ早かれ切られるものなら4から5になった時点で切り離すべきだよ
Perlと同じ運命をたどるのはあまりにも芸がないし行き詰まるよ
実際、PHP5も行き詰まっているみたいだし下位に拘りすぎると出来る事が限られてしまう

PHP5のPHP4への対応はphp.iniにあるけど、それなら素直にPHP4を使っておけば良いよ

436 :nobodyさん:2005/04/10(日) 00:54:32 ID:GMsPYp/4
しかしPHP5対応のレンタル鯖がほとんど無いのは痛いな

437 :nobodyさん:2005/04/10(日) 08:25:06 ID:???
別に痛くはないよ
大規模なスクリプトを使うサイトなんて共有鯖でするものではない、
故にPHP5である必要もない


438 :nobodyさん:2005/04/10(日) 11:11:29 ID:???
PHP5 使いたいなら海外の無料サーバ使えばいいのに。
って、英語できない、とほざくのかな。

439 :nobodyさん:2005/04/10(日) 12:40:03 ID:???
問題なのはZendとユーザーの温度差。

440 :nobodyさん:2005/04/10(日) 12:45:49 ID:???
phpを使ってあげているのか、使わせて貰っているのかだな
何でも当たり前と想ってる事に問題はないのか?

441 :nobodyさん:2005/04/10(日) 15:18:51 ID:???
ユーザーは使わせてもらっていると思ってる。
Zendは使わせてやってると思ってる。

442 :nobodyさん:2005/04/10(日) 19:48:42 ID:???
普通じゃない?

443 :nobodyさん:2005/04/10(日) 20:03:28 ID:???
>>438
PHPを使うためにレン鯖借りるわけじゃなく、レン鯖借りたら載ってるからPHP使うだけの人がほとんどだし。
PHPを使うために借りてる人は、すでにPHP4対応の鯖借りてて乗り換えるのも面倒だと。

444 :nobodyさん:2005/04/10(日) 20:30:20 ID:???
zend社とワイズノットって仲好しなの?

445 :nobodyさん:2005/04/10(日) 23:05:23 ID:???
日本のPHP/Zend周辺の会社はどれもヘンなのばっかりな

446 :nobodyさん:2005/04/10(日) 23:22:16 ID:???
ワイズノットは、ThinkITのPHPとJavaの比較記事を読んで、お笑い系の会社だという認識になったんだけど、どうなの?
こんなバカなことをもっともらしく言う人が技術リーダーとかいう肩書きなのか、と。
あの記事で、ThinkIT自体見る気なくなったわけだけど。

Zendとワイズノットは、検索すると提携の記事がたくさんひっかかるよ。
結局、こんなところが「オフィシャルトレーニングセンター」とかになってるからPHPが広まらないんじゃないかと思ってみたりする。

447 :nobodyさん:2005/04/11(月) 00:08:11 ID:???
ワイズノットの会社説明会で貰った資料に
「JAVAによる開発費用の半額で開発が可能(設計工数は変わらず、
開発工数が半減します。」って書いてある。

448 :nobodyさん:2005/04/11(月) 01:06:59 ID:???
「なぜならウチにはJavaのノウハウがないからです。」
と続く。

449 :nobodyさん:2005/04/11(月) 02:19:01 ID:???
いまさらJavaって言われてもなぁ。
学校でもPHP教えてるなんてのをどっかで見たけどほんとなの?
IBMがPHPの開発をやめるように働きかければPHPが消える可能性はあるけどね。

450 :nobodyさん:2005/04/11(月) 03:16:54 ID:???
今更JAVA?

451 :nobodyさん:2005/04/11(月) 04:58:07 ID:???
>>449
普通高校の技術の時間にやるくらいなら、PHPでもいいかもね。

452 :nobodyさん:2005/04/11(月) 10:18:27 ID:???
JSPと比較しても良いけどJAVAとは比較するな

453 :nobodyさん:2005/04/11(月) 10:19:10 ID:???
なんで?

454 :nobodyさん:2005/04/11(月) 15:34:11 ID:???
>>452はおおかた1つのPHPスクリプト中にコードもテンプレートも混ぜてるんだろ

455 :nobodyさん:2005/04/13(水) 23:24:25 ID:???
いつになったらPHP1色の時代になるんですかぁ?

456 :nobodyさん:2005/04/13(水) 23:40:33 ID:???
言語だろうが思想だろうが何か一色なんてありえないね。
その上でシェア率を言うならどうなんだろうね。

457 :nobodyさん:2005/04/14(木) 06:07:13 ID:???
CGIはほぼPerl1色ですが、何か?

458 :nobodyさん:2005/04/14(木) 07:08:02 ID:???
>>457
初心者が多いからPerlだろうな。
機能的に優秀なものや商業利用されているCGIは殆どC言語だよ。

459 :nobodyさん:2005/04/14(木) 08:13:18 ID:SWXhJYok
CGIなんてもう使われてないだろ。


460 :nobodyさん:2005/04/14(木) 09:25:38 ID:???
Perl が多いのは過去の資産であって、
新規案件で Perl って PHP に比べると少ないよね
Ex. sourceforge, freshmeat

461 :343:2005/04/14(木) 11:21:34 ID:???
ttp://www.hotscripts.com/
PHPって誰でもできるからかな

462 :nobodyさん:2005/04/14(木) 11:26:41 ID:???
Perl6 は敷居高いしね
Ruby, Python は OO だから?か人気ないし
消去法で PHP が選ばれているのかな

463 :nobodyさん:2005/04/14(木) 11:35:36 ID:???
人気が出るかは、無料有料問わずに鯖次第。

全国的に鯖がJavaとか使える状況ならJava1択だったかもしれない。
OSすら制限無くなれば、ASP.NETも一般人にも普及するかもしれない。

Ruby、Pythonは使える鯖が少ない。
Perlは大体何処でも使える。
PHPも最近では珍しくも無い。
この現状を見れば鯖依存だということは明らか。

464 :nobodyさん:2005/04/14(木) 12:02:39 ID:???
>>460
CGIでPHPを使う人がそんなにいるとでも?

465 :nobodyさん:2005/04/14(木) 23:53:09 ID:???
俺今派遣で働いてるんだけど、Web系はJavaとPHPの案件しか無いね。
たまにPerlもあるけどごくまれ。でもPHP5を使ってるところは無い。

466 :nobodyさん:2005/04/15(金) 00:15:02 ID:???
PerlってPHPと比べると激遅じゃん
って言うと語弊があるんだけどmod_perlで作るとなると
にわかPerlerでは無理になる
なので
安く作りたいなら PHP
少し高くても強固に作るなら JAVA
Perlは中途半端

467 :nobodyさん:2005/04/15(金) 00:41:39 ID:vd7PoSCx
>>466
スクリプト群の流れは今後Parrotに収束するよ。
Perl6とPythonの時期バージョンのエンジンはParrotということで決定してるし、
PHP6とRubyでもParrotを採用するという動きがある。
そうなると言語はPerlだろうがPHPだろうが好きなの使いなよってことになる。

ちなみにPerl6の進化はPHP4→PHP5ていどのぬるいバージョンアップとは
違って半端無い改良が加えられる。正規表現の改良なんかは正直PHPみたいな
パクリ言語ではもう付いていけないレベル。
もちろんPHPみたいに下位バージョンを切り捨てたバージョンアップとは違い
Parrotで動くPerl5を作るなどの対応も欠かしてない。

今年やっとParrotがリリースされるということだから楽しみに待ってな。

468 :nobodyさん:2005/04/15(金) 01:22:45 ID:???
ParrotってVMみたいな感じかな
モジュールとして動くperl、phpとVM上で動くperl、phpの
速度の優位性はどんなもんなんだろう。
それはさておきparrotによって何が変わるのかを予測すると

-perl5/CGI → perl6/parrot-
速度を考えた場合、mod_perlのように気を遣わなくても早く実行できるコードを書ける?
strictがデフォでonになるため敷居が高くなる
様々な機能追加や見直し

-mod_php → php/parrot-
今までPHPが使えないサーバーがある事があったがperlと同等のレベルで
parottが導入されればほとんどのサーバーでphpが使えることになる
cpanの豊富なモジュールが利用可能になる
cheapな管理体制による脆弱性などの露呈、対応がperlクオリティになる

パクリ言語なPHPがPerlに対して劣勢であると言われていた部分が見事に解消
する事になる。それも比較されていたPerlのチームが作ったparrotによって。
皮肉なものだ。
しかしLarryはその事に悲観する事はないのだろう。

469 :nobodyさん:2005/04/15(金) 01:59:52 ID:nt16wJOR
じゃPHP最強じゃん

470 :nobodyさん:2005/04/15(金) 02:04:19 ID:???
そこへ新しい言語nullpoが登場。

471 :nobodyさん:2005/04/15(金) 02:40:21 ID:???
PHPはPerlには一生追いつけない。これは確実に言える。
言語学者が作った言語とパクリ野郎が作った言語ではレベルが違いすぎる。
Perl6の正規表現がどんなレベルになっているか知ってるか?

472 :nobodyさん:2005/04/15(金) 03:02:58 ID:???
私もそう思う
Larryの思想は壮大で心が破裂しそうだがzendは尊敬出来ない。
言語としてみてもPHPは底の浅さを隠しきれない
しかし受け側はそんな事には興味が無いのが事実なのだ。
例え蛆虫が沸いてる肉を使おうが安くて早くて美味ければそこに群がる。
この状況がWEBに止まらずアプリ等にも波及した時のことを考えるとゾっとする。
しかしそれは正常進化であるのだ。

473 :nobodyさん:2005/04/15(金) 10:35:03 ID:???
>>472
PHPの場合、美味くなくても肉の味がすれば群がる、の方が適切かと。
肉食ったことがない人が、「へ〜これが肉かぁ」って感じで。

474 :nobodyさん:2005/04/15(金) 10:56:44 ID:???
PerlやPHP、その他のobj言語も使うけど利用者にしてみれば同じ結果が出るのなら
楽なのを使うのが普通だろ、言語そのものの評価など関係ない。言語が素晴らしい
なんて言っているのは負け組みの言い訳。



475 :nobodyさん:2005/04/15(金) 11:09:23 ID:???
というのが負け組のいいわけだな。
プラットフォームの評価は関係あるだろ。
というか、同じ結果をだすのにPHPは楽じゃないってことだ。
あいかわらずバージョンアップでエンバグしてるし。

476 :nobodyさん:2005/04/15(金) 11:54:02 ID:???
つか Perl6 の正規表現ライブラリも
preg のように公開されるので PHP でも
使えるのだけど何を言っているんだ?

477 :nobodyさん:2005/04/15(金) 12:00:01 ID:???
どの言語で迅速な開発が出来るかは人それぞれだからね
実行や処理速度だけを考えて極めるなら機械語を使えば良いだけだしな

>>475
プラットホーム・・・ふ〜ん

478 :nobodyさん:2005/04/15(金) 12:20:12 ID:???
PHPで出来ることはすべてPerlでできる。
Perlで出来ることのすべてをPHPではできない。

479 :nobodyさん:2005/04/15(金) 12:24:38 ID:???
>>478
ふーん、例えば?

480 :nobodyさん:2005/04/15(金) 12:28:19 ID:???
PHPでApacheモジュール作れるんだっけ?

481 :nobodyさん:2005/04/15(金) 13:06:01 ID:???
>>478
Perl で例外とか綺麗な OO 書けないだろ
あと可読性とかさ

482 :nobodyさん:2005/04/15(金) 13:12:31 ID:???
どんな言語も一長一短、だからこそ世の中には色んな言語がある

483 :nobodyさん:2005/04/15(金) 13:55:00 ID:???
チンポと同じだね>>482

484 :nobodyさん:2005/04/15(金) 13:56:17 ID:???
>>482
同感。Perl, PHP, Ruby, Python, Java, C++ 使うんだけど
それぞれにいい所があるね。
PHP4 はひどかったけど PHP5 は本当によくなった。
# C# 勉強中

485 :nobodyさん:2005/04/15(金) 17:52:16 ID:???
>>483
おいおい、チンポはそんな一言で片付くものじゃないぞ。
99%以上の男はチンポが左に曲がっていることが保障されているんだよ。
ほとんどの人はパンツメーカーが左向きに矯正したことに気づいていないだけなのさ。
もしかしたらおまいの人生や日本の経済が曲がっちまったのもチンポの曲がりが原因かもしれないぞ!
一歩先行く男はチンポとPHPを右向きに矯正して風俗のねーちゃんにアピールすることをお勧めするyo.

486 :nobodyさん:2005/04/15(金) 18:17:53 ID:???
俺、激しく右曲がりだ・・・


487 :nobodyさん:2005/04/15(金) 19:05:19 ID:???
PHP5で実際にシステム組んで
稼働させてる人いますか?

488 :nobodyさん:2005/04/15(金) 19:17:53 ID:???
>>487
俺の会社だと、既にPHP5でシステム作って納品して本番稼動させてる。

489 :nobodyさん:2005/04/15(金) 19:22:31 ID:???
>>488
マジですか。
それならウチもそろそろPHP5に行きます。
PHP4のオブジェクトは
生成するたびメソッドまで無駄にコピーされてるかと思うと
気持ちが悪いし…

490 :nobodyさん:2005/04/15(金) 19:29:16 ID:???
社内システムは PHP5 に移行してガンガン使ってる。
全く問題ないから近々 PHP5 のプロダクトをリリースさせるよ。

491 :nobodyさん:2005/04/15(金) 20:07:34 ID:???
>生成するたびメソッドまで無駄にコピーされてる
そんなことはない。プロパティと間違えてないか?
PHP4でも、そういうところに気を配るプログラマはきちんと参照を使うもの。

492 :nobodyさん:2005/04/15(金) 20:28:31 ID:???
>>491
君はもう一度勉強し直した方が良さそうだな。

493 :nobodyさん:2005/04/15(金) 23:11:24 ID:DK+hN0WB
parrotが出た後は速度面の比較は意味がなくなるから
以下に楽に書けるか、保守や再利用性が増すかという点が重要になる。
PHPはJavaの真似したりしてその動きがあるけどPerlは何してるの?

494 :nobodyさん:2005/04/16(土) 00:57:07 ID:???
Perlも$a->{b}->{c}を$a.b.c とか$a.b.c.len とか書けるようになるね。
再利用性や保守も考慮にいれてRFC作ってるらしいけど情報が
少なくてどう転ぶかはまだわからない

495 :nobodyさん:2005/04/16(土) 02:10:20 ID:???
でも、Parrotになるなら、もうPerlだのPHPだの、どうでもよくなって、使いたいもの使えば?って感じだね。
結局動作環境としてのPHPは無くなって、言語としてだけ残るってことでしょ?
とはいえ、関数ってどうなるの?
Parrot用に移植する必要があるんだよね?
で、そしたらParrot上のPerlからもその関数呼び出せるんだよね?
なんか、そしたらRubyとかPythonとか、PHPより書きやすい言語に移行していったりするんじゃないかな。
PHPは型なし言語のくせにJavaみたいな言語構造だから、型あり・型なしの悪いとこ取りって感じだし。

496 :nobodyさん:2005/04/16(土) 02:30:14 ID:???
>>491
PHP4は「なんちゃってオブジェクト指向」なのでnewのたびメソッドすらコピーされますよ。

497 :nobodyさん:2005/04/16(土) 07:42:39 ID:???
>>495
個人単位ならそうかもしれないけど企業的には技術者が多く
初心者でも扱えて単価が安いPHPを使うことが多くなるんじゃないかな

498 :nobodyさん:2005/04/16(土) 07:55:04 ID:97gwJhd3
国内は数年は4がメインだろうね

499 :nobodyさん:2005/04/16(土) 08:11:13 ID:???
>>498
既に新規案件はPHP5ですね。
ただし、PHP4で作った既存システムはそのまま数年動く。
だから、4がメインだと錯覚してるだけ。

500 :nobodyさん:2005/04/16(土) 08:24:35 ID:97gwJhd3
まぁ現実どうなるか見物ですね

501 :nobodyさん:2005/04/16(土) 08:36:08 ID:???
多分現状日本でのシェアは 9.5:0.5 ぐらいじゃない?

502 :nobodyさん:2005/04/16(土) 08:44:01 ID:97gwJhd3
5で作ったが5の鯖ね―じゃんとの、クレ―ムで4に変えた、広い意味で5やPHPの必要性を感じなくなったな

503 :nobodyさん:2005/04/16(土) 09:16:34 ID:???
PHPはプログラミング言語というより、Word/Excelといったようなツールとしての色が強い。
オブジェクト指向なんて使う必要がないぐらい手軽になったほうがPHPらしいと思う。

504 : ◆yflOPYrGcY :2005/04/16(土) 12:09:19 ID:jM9m/cwL
オブジェクトがあるからこそ本当のphpに出会える

505 :nobodyさん:2005/04/16(土) 12:30:28 ID:???
Zendだけでなくユーザーも迷いに迷うPHPw

506 :nobodyさん:2005/04/16(土) 14:40:48 ID:???
派遣会社紛いのSI企業が人売りで金を稼ぐならPHPでしょ(藁
初心者に一ヶ月くらい教えたあとにOJTと称して客先へポイっ

どこかの会社がやってることさ(藁
どことは言わんが。

507 :nobodyさん:2005/04/16(土) 17:41:52 ID:???
全て頭の中にあるのなら迷う事はない
迷う奴はただのへたれ

508 :nobodyさん:2005/04/16(土) 20:02:23 ID:???
次世代プログラミング言語Nullpoマダ?

509 :nobodyさん:2005/04/16(土) 20:27:19 ID:???
うるせーバカ

510 :nobodyさん:2005/04/16(土) 23:10:54 ID:???
OOP面白いよ
子どもの頃プラモ作った時みたいな感じに作れるし
一回やったら戻りたくない

511 :nobodyさん:2005/04/16(土) 23:38:29 ID:???
OOPはPHPでWebでやるより、JavaなりC#なりでウィンドウに何か表示してやったほうが一層おもしろいよ。

512 :nobodyさん:2005/04/17(日) 02:07:22 ID:T6yAigWO
国内レン鯖PHP5に移行する気配全く無し、それどころか今だに、多数4.3.6のままも多いね、底辺が変わらない事には5なんて必要なのか?

513 :nobodyさん:2005/04/17(日) 08:41:23 ID:???
>>512
必要ないよ。
PHP5に移動出来るのは鯖とスクリプトの両方を提供しているビジネス会社だけ。
まだまだ自己満足の世界でしかない。

514 :nobodyさん:2005/04/17(日) 09:57:49 ID:???
すべてZendの責任。

515 :nobodyさん:2005/04/17(日) 10:45:52 ID:???
4でも5でも動くスクリプトを提供するのがプロの仕事、
それが出来ない素人はすぐに責任転嫁する

516 :nobodyさん:2005/04/17(日) 14:17:30 ID:???
4でも5でも動くとなると、5で変わった点は殆ど生かされないよね。

517 :nobodyさん:2005/04/17(日) 15:32:58 ID:???
>516
phpversionで、読み込むファイル変えればいくらでも生かされるが

518 :nobodyさん:2005/04/17(日) 15:53:40 ID:???
頭の悪い奴は自分の小ささを知らない

519 :nobodyさん:2005/04/17(日) 16:29:02 ID:???
まさか2つファイルを作るって話?

520 :nobodyさん:2005/04/17(日) 17:06:53 ID:???
>>519
何で2つ作っちゃいけないんだ?
頭かたすぎるだろ

521 :nobodyさん:2005/04/17(日) 17:18:12 ID:???
なんでPHP5マンセー者はバカすぎるんだ?
結局PHP5の機能を使わないファイルを作るなら、PHP5の機能を使わないファイルだけでやるだろ。

無職ひきこもりで時間がありあまってるやつは別だけどね。

522 :nobodyさん:2005/04/17(日) 17:45:25 ID:???
>>521
レス番つけて文句言えよ、ついでに流れ読め

523 :nobodyさん:2005/04/17(日) 17:49:01 ID:T6yAigWO
そんな事までしなきゃ5って使えないよね、しかも素人が使うフリ―スクリプトには使えない物続出だろうな

524 :nobodyさん:2005/04/17(日) 17:52:07 ID:???
>>523
素人が使うようなフリースクリプトなんて、ほとんどPHP5でも動くぞ。
何せ、難しい事してないからな。
構造やらソースは物凄くシンプル。

企業で書くような大規模で再利用性を考えたプログラムの方が動かない。


525 :nobodyさん:2005/04/17(日) 17:55:46 ID:???
>>522
ほら、こんな感じで、ちゃんと本人には伝わってるし。

526 :nobodyさん:2005/04/17(日) 17:56:42 ID:???
>>524
つまり、いいプログラムほどPHP5では動かず、どうでもいいプログラムばかりがPHP5で動くってことですね?

527 :524:2005/04/17(日) 18:14:01 ID:???
>>526
そういう意味じゃない。
シンプル・イズ・ベストの言葉の通り。

528 :nobodyさん:2005/04/17(日) 18:15:51 ID:T6yAigWO
なんか5支持には無理があるね、5が出なきゃ良かったのかもね、

529 :nobodyさん:2005/04/17(日) 18:19:23 ID:???
PHPが複数のバージョンで動くなら問題無いんだよ。

.NetFrameworkなんて1台のPCにバージョンの違うランタイム入れても、
それぞれが独立していて、問題無く動く。
この仕組みはそれは凄く評価してる。

いい加減バージョンの違いによる・・・っていうのはいい加減にして欲しい。

530 :nobodyさん:2005/04/17(日) 18:24:40 ID:T6yAigWO
確かにそうですね、僕も、ちょっとバ―ジョンが変わるだけで動かない等のクレ―ムには疲れた、しかもこの先も、ずっと同じ事起きるしね、未来のバ―ジョン予測なんて、できね

531 :nobodyさん:2005/04/17(日) 18:37:46 ID:???
そこでParrotの登場ですよ。
Perlの場合Perl5とPerl6では互換性は無いが
Parrot側でそれをカバーしてる。
PHPでも同じことをすれば良し。

532 :nobodyさん:2005/04/17(日) 18:39:24 ID:???
有償スクリプトならサポート料をぼっているはず
無償スクリプトならサポートする必要はない
無償でサポートしている奴が馬鹿

533 :huhu:2005/04/17(日) 18:45:28 ID:xsrZayHP
常時450本以上のモロ動画完備の裏ビデオ通信!
明乃夕奈のタダ動画あり!一見の価値ありです。急いでDLしよう!
↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓
http://www.pinkeyes.tv/

534 :nobodyさん:2005/04/17(日) 19:21:58 ID:???
PHP4のスクリプトがPHP5で動くっていうやつは、ほとんど動くっていってるだけで、動作の保証がされているもんでもないし。
つうか、PHP4の中でもバージョン間で動く動かないあるのに、PHP5に移行出来るかって感じだな。

535 :nobodyさん:2005/04/17(日) 19:26:35 ID:???
>>531
Parrotについては詳しくしらないが、『互換性』とかカバーとか要らない。
単純にPerl5とPerl6がそれぞれ独立してインストール出来て、
それを使うアプリ側がバージョンを指定して動けばいい。

そうすれば、1つのサーバの中でどっちのバージョンも動くから、
使いたい方を使えばいい。

536 :nobodyさん:2005/04/17(日) 19:35:23 ID:???
よくわからんが、Linuxのカーネルみたいなもんで、
そうそう全面移行ってのはないんじゃない?
動いているモノに、わざわざ手を入れる必要はないし。

537 :nobodyさん:2005/04/17(日) 19:37:32 ID:T6yAigWO
有償サポ―ト出まくりでPHPうざすぎなんだよ、しかも素人相手だからな、おとなしく5使うのやめたよ。PHPはお気軽だから好きなんだけど、なんにも考えてないバ―ジョンアップには耐えられないな。

538 :nobodyさん:2005/04/17(日) 19:38:07 ID:???
今の現状を見れない奴がPHP5と騒いでいるだけだよ
気にするな

539 :nobodyさん:2005/04/17(日) 19:40:47 ID:???
わかってないな・・・ちゃんと書いている奴のスクリプトでは問題が起きない
へたれが適当に書いて動いたって喜んでいるから問題が起きる

540 :nobodyさん:2005/04/17(日) 19:46:41 ID:T6yAigWO
ま―へたれでもなんでもなくても4で作って5で動かない事は十分ある。その辺十分理解できてる奴は理解できるが、理解出来ない奴も多い、つまりPHP自体理解してないのかもね

541 :nobodyさん:2005/04/17(日) 19:49:54 ID:???
妄信もほどほどにね^^;

542 :nobodyさん:2005/04/17(日) 19:52:21 ID:???
きっと、どんな糞言語になってもZendは悪くない。アホには使いこなせないのだ。悪いのはアホユーザーだ!!
と言い張るんだろうな。
どっかの国の人みたいだ。

問題点は削っていこうよ。

543 :nobodyさん:2005/04/17(日) 20:05:36 ID:T6yAigWO
PHP好きなのはわかるけど、現状見れば4もしくは他言語が無難、ぶっちゃけ、日本だけじゃなくて海外でも同じ現状だよ

544 :nobodyさん:2005/04/17(日) 20:31:53 ID:???
もう駄目だZendのせいでPHPは終わった。

545 :nobodyさん:2005/04/17(日) 20:43:28 ID:???
IBMのおかげで新たに始まる。

546 :nobodyさん:2005/04/17(日) 22:27:30 ID:???
実際問題として、web上のCGI言語で使われてるのは
圧倒的にperlが多いわけだがw

547 :nobodyさん:2005/04/17(日) 22:29:42 ID:???
ま、CGIだしね。
まともに使うものはCGIにしないわけで。
PHPなんてCGIで使ってる人なんてほとんどいないわけで。
JavaをCGIで使うのはバカだし。

548 :nobodyさん:2005/04/17(日) 23:24:46 ID:???
安全性を考える人はPHPでもCGIで動かしてるわけで。

549 :nobodyさん:2005/04/17(日) 23:27:50 ID:???
PHPの良い点って速さって言うより
プログラマにとって開発のしやすさだと思うんだけど。

550 :nobodyさん:2005/04/17(日) 23:37:35 ID:???
>>549
どっちかっつーと手軽さだと思うんだけど

551 :nobodyさん:2005/04/18(月) 00:34:53 ID:???
まともな開発環境もないのに開発しやすいかねぇ。
とっつきやすくて手軽というだけだよ。

552 :nobodyさん:2005/04/18(月) 00:35:41 ID:???
>>548
というか、安全性を考える人はPHPを使わない。

553 :nobodyさん:2005/04/18(月) 00:53:51 ID:???
なんかPHPが叩かれまくってるな。

554 :nobodyさん:2005/04/18(月) 01:04:15 ID:???
まるで日中関係のようだな

555 :nobodyさん:2005/04/18(月) 01:25:09 ID:???
お手軽すぎて、>>1-554みたいなプログラマ気取りが増えるんだよ。

556 :nobodyさん:2005/04/18(月) 01:31:06 ID:???
>>555
で自称プログラマのあなたはどのような言語をお使いなんですか?

557 :nobodyさん:2005/04/18(月) 02:07:46 ID:???
そりゃSmalltalkにきまっとる。

558 :nobodyさん:2005/04/18(月) 02:33:37 ID:XuxjWdhQ
なんかもう、5は・・・かばいようも無いようだ・・。

559 :nobodyさん:2005/04/18(月) 02:44:59 ID:???
>>557
Smalltalkって元祖オブジェクト指向言語だっけ?
MVCモデルも採用してたとか。

560 :nobodyさん:2005/04/18(月) 02:52:47 ID:???
DebianでPHP5をapt-getでインストールしようとしたら
stableに無いのよ。で、tesingも探してみたんだけど無い。
PHP5はDebianコミュニティから完璧に無視されてるってことだ。
まったくこれは完璧にZendの責任だな。
ユ ダ ヤ 人 は こ れ だ も の

561 :nobodyさん:2005/04/18(月) 02:53:52 ID:???
PHP5のおかげでPHPは終わったな。

562 :nobodyさん:2005/04/18(月) 03:52:21 ID:???
PHPは何度でもよみがえるさ

563 :nobodyさん:2005/04/18(月) 04:09:41 ID:???
そのたびにすぐあぼーんするわけだね。

564 :nobodyさん:2005/04/18(月) 06:40:18 ID:???
PHPは終了ってことでFA?

565 :nobodyさん:2005/04/18(月) 10:29:32 ID:???
いや、厨がいる限りしぶとく続くと思う。
MSXみたいなもん。

566 :nobodyさん:2005/04/18(月) 12:30:04 ID:???
phpのいい点は、Cライクで文法を最初からおぼえ直したりすることなく、
すんなりと導入できるところだ。

567 :nobodyさん:2005/04/18(月) 13:02:23 ID:???
迅速な開発、これが最大の理由
それもわからない奴はC言語つかっとけって話

568 :nobodyさん:2005/04/18(月) 16:01:40 ID:???
>>566
それを言うなら、PerlもRubyもJavaも、ほとんどCライクっていえる。
PHPは迅速に開発にとりかかれるけど、始まった開発は迅速には進まない。

569 :nobodyさん:2005/04/18(月) 18:48:02 ID:???
>>568
始まった開発が迅速に進まないのはPHPじゃなくてプログラマの頭が悪いんじゃないかな

570 :nobodyさん:2005/04/18(月) 20:06:54 ID:???
>>568
PHPもろくに使えないんですか?

571 :568:2005/04/18(月) 22:08:19 ID:???
そうだね。
頭悪いからPHP使いこなせないんだと思う。
だからツールやらライブラリやらドキュメントが揃ってて変なエンバグのないJava使ってるんだと思うよ。

PHPはツールがなくてライブラリのドキュメントも揃ってなくて変なエンバグがしょっちゅうあっても対応できるような賢い人が使うんだろうね。
選ばれた人だ。

572 :nobodyさん:2005/04/18(月) 22:27:11 ID:???
>>571
>変なエンバグのないJava
Javaのエンコードに不具合があるのを知らない程、頭悪いとは・・・
おわっとる・・・

573 :nobodyさん:2005/04/18(月) 23:19:54 ID:???
ケンカはやめてセックスしなよセックスセックス!

574 :nobodyさん:2005/04/19(火) 00:09:24 ID:???
でもJava使いってプログラミングの上っ面しか知らない
ウンコちゃんが多いよね。

575 :nobodyさん:2005/04/19(火) 00:26:36 ID:2zaxXYWz
え?
PHP使いのほうが上っ面多くない?
説明する気も萎えるくらい
「あれ?こういう概念知らないんだ、ふーん」ってなることがある。
そして、概念も概要とか、知ってる言葉を振りかざすだけで、
未検証、評価の精度が低い。


576 :力を貸して下さい:2005/04/19(火) 01:58:20 ID:/22NR/re
↓の文をコピペして他スレに貼ってき、同志を集める。

【反日】対中サイバー戦【抗日】 Part4
http://academy3.2ch.net/test/read.cgi/china/1113840522/


中国共産党思想統制開放作戦を決行します。
みんなで中国サイト掲示板に書き込もう!
公安によってすぐに削除されますが、一瞬でも見た中国人が己の過ちに気づき矛先が中国政府に向かいます。
このレスを他関連スレに貼り付けてくれると助かります!



577 :nobodyさん:2005/04/19(火) 02:56:35 ID:???
>>575
Java使いって正規表現すら理解できてない奴多いよ。
お前テキスト処理の基本だろってなことも知らない。

578 :nobodyさん:2005/04/19(火) 03:37:22 ID:2zaxXYWz
そういう香具師はPerlをやってきてないよね。

579 :nobodyさん:2005/04/19(火) 03:56:41 ID:???
>>568
ついでに、"人気がある言語"これだね。

580 :nobodyさん:2005/04/19(火) 04:22:45 ID:2zaxXYWz
人気がありすぎて、
俺様仕様で勝手創造的PHPシステムが
乱造されててウザイ。
他人が作ったサイトをちょっくら面倒見るときに
そういうことが発生しまくる。
JavaでStrutsはちょっと冗長だけど、
それでもJavaならStrutsで済むんだけどーって思う。
PHPのフレームワークは今出回ってるいい感じのやつを使ってほしい。
俺様フレームワークに出くわしたときはマジうざかった。

581 :nobodyさん:2005/04/19(火) 04:42:48 ID:???
>>572
バグがあるのと、エンバグがあることは全く違うよ。
バグはソフトウェアである以上しかたないけど、バージョンアップでバグが入るというのは開発プロセスの問題。
今まで動いてたプログラムが、セキュリティパッチで関係ないところで動かなくなるっていうのが頻発するっていうのは、メジャーな処理系ではPHPくらいしか聞かない。

582 :nobodyさん:2005/04/19(火) 04:49:45 ID:???
>>577
「PHP使い」の方にこそあてはまる気がするんだが。

583 :nobodyさん:2005/04/19(火) 08:43:15 ID:???
Windowsもバージョンアップやパッチで動かない物がある
データにしても下位のものは切り捨てられる事はある
ついて行けない奴は何処の世界でも置いて行かれる


584 :nobodyさん:2005/04/19(火) 09:20:12 ID:???
PHPの規模のプロダクトなのに、Windows規模の開発と同じ混乱が発生してるということか。
「フォームが崩れる」とかいっちょまえなこと言って部活さぼってる中学生みたいだな。

585 :nobodyさん:2005/04/19(火) 10:40:14 ID:???
Windowsが有償な事を考えたら大差ないだろ
大きい物に巻かれる日本人は小さい所を叩きたがるからな

586 :nobodyさん:2005/04/19(火) 11:31:31 ID:???
PHPって小さいんだwwww
PHP1色はまだまだ先だな

587 :nobodyさん:2005/04/19(火) 11:51:08 ID:???
PHP、1色なんてありえない
そんな事もわからないのか・・・
そういうレベルなのか・・・

588 :nobodyさん:2005/04/19(火) 16:32:50 ID:???
もうすぐParrot一色だし。

589 :nobodyさん:2005/04/19(火) 21:55:54 ID:???
>>585
ある意味最も条件が過酷なOSと、特定用途のスクリプト言語を大差ないと言えるところが、PHP厨らしくてイカス!

590 :nobodyさん:2005/04/19(火) 22:17:14 ID:???
もうこれはすべてZendの責任だな。

591 :nobodyさん:2005/04/19(火) 22:34:20 ID:???
批判するなら使うなよ
使わないならこのスレに来るなよ
余所のスレで騒げ、厨諸君w

592 :nobodyさん:2005/04/19(火) 23:24:06 ID:???
>>591
君が一番、このスレ来る必要ないと思ううううふ
ネタスレだじょ
もしくは、批判厨の隔離スレとでも思えば問題なかろう

593 :nobodyさん:2005/04/19(火) 23:28:01 ID:???
>>592
悪いな・・・融通効かなくてw
真面目だねって良く言われるよ

594 :nobodyさん:2005/04/20(水) 00:01:23 ID:???
PHP5のおかげでPHPの地位は急降下。
それを指摘されて逆切れするPHP厨はZend並にどうしようもないね。

595 :nobodyさん:2005/04/20(水) 01:14:56 ID:???
もうこれはすべてZendの責任だな。

596 :nobodyさん:2005/04/20(水) 03:02:08 ID:M6NXhxaM
誰か頼むからPHP5の使えるレンタルサーバーを教えてくれ。

597 :nobodyさん:2005/04/20(水) 06:55:46 ID:???
>>591
> 批判するなら使うなよ

つまり、信者以外は使う価値なしと。

598 :nobodyさん:2005/04/20(水) 07:15:47 ID:vYzziVN+
5鯖借りたら、4になったよ。。レンタル鯖は都合で5から4へ。。。専用じゃないと5は厳しいのかもね。。おそらく4使ってる奴に不具合出て戻したのかもな。。

599 :nobodyさん:2005/04/20(水) 10:35:31 ID:???
つまり、信者以外は使う価値なしと。

600 :nobodyさん:2005/04/20(水) 12:48:49 ID:???
これはもうZendとユーザーのコンクラーベだな。

601 :nobodyさん:2005/04/20(水) 13:03:36 ID:???
問題が起こっても自分で対処できるやつはPHP使えばいいし、
ベンダーに責任転嫁できたほうが嬉しい奴はJavaを使えばいいってことでいいんじゃねーの?


602 :nobodyさん:2005/04/20(水) 13:51:51 ID:???
PHPで起こるような問題が起こらないJavaのほうがいい。
PHPの問題を自分で対処するくらいならJavaの問題で自分で対処するほうがいい。

603 :nobodyさん:2005/04/20(水) 14:43:32 ID:zBOzZqCx
責任転嫁のベストプラクティスはC丼w

604 :nobodyさん:2005/04/20(水) 16:12:49 ID:???
バージョンアップ毎に問題が起きるような処理系を
公開しているようなZendはもう無くなってしまえばいいと思うよ。

605 :nobodyさん:2005/04/20(水) 16:49:33 ID:???
専用サーバならServletもいいけど、レンタルサーバで運用するような案件だと
要求に合ったServlet環境を探し出すのが難しくないかい?


606 :nobodyさん:2005/04/20(水) 17:23:21 ID:zBOzZqCx
まさしくそこでPHPなんだけど、
まさしくそこで俺様newbie達が大暴れしてくれてる。

607 :nobodyさん:2005/04/20(水) 19:59:49 ID:???
>>605
要求にあったPHP5環境を探し出すのも、同じくらい難しいね。

608 :nobodyさん:2005/04/20(水) 20:31:25 ID:???
もうこれはすべてZendの責任だな。

609 :nobodyさん:2005/04/20(水) 21:20:07 ID:???
つうかさぁ、PHPはいいとしても、中国の反日デモはどうにかして欲しいよね。
Zendの責任なんだから。

610 :nobodyさん:2005/04/20(水) 21:21:23 ID:???
おめーら黙って聞いてりゃいい気になりやがって!
Zendの責任にすんなよな!

611 :nobodyさん:2005/04/20(水) 21:38:25 ID:???
ZendのアホがしっかりしてないからPHP5を誰も使おうとしない
今のような状況になったんだよ。

612 :nobodyさん:2005/04/20(水) 21:57:44 ID:???
Zend = 悪の枢軸

613 :nobodyさん:2005/04/21(木) 00:01:09 ID:???
温暖化もZendの責任だ

614 :nobodyさん:2005/04/21(木) 00:12:49 ID:???
いやぁ、温暖化は、PHP3のころに周り勧めた俺にも責任がある。

615 :nobodyさん:2005/04/21(木) 02:58:17 ID:???
もうこれはすべてZendの責任だな。

616 :nobodyさん:2005/04/21(木) 03:20:11 ID:???
このスレザーッと読んでみたんだけど
PHPはもう終了ってことでOKですかね?

617 :nobodyさん:2005/04/21(木) 03:22:21 ID:???
>>616
OK

618 :nobodyさん:2005/04/21(木) 04:49:02 ID:???
PHPは何度でも蘇るさ

619 :nobodyさん:2005/04/21(木) 05:01:57 ID:???
そのかわり、いままでのスクリプトは使えなくなるけどな。

620 :nobodyさん:2005/04/21(木) 06:06:43 ID:9MPKObNf
進化するだびに過去のスクリプトとの互換性無いとは、もはやPHPを必要とする意味が見当たらない。。

621 :nobodyさん:2005/04/21(木) 06:37:37 ID:???
PHPは正直言ってWindows使ってCGI使ってる奴にしか需要ないだろ?
なぜならPHPはUNIX系OSでは使えないからだ、どうせCGI作るならUNIX系にも
対応しているPerlのほうが使い勝手がいい

622 :nobodyさん:2005/04/21(木) 08:54:42 ID:Y+A3+t7R
携帯コンテンツ屋です。
最近PHPばっかしでちょっとうんざり。
たまにjspで書くと、変数に$つけてしまうとです。


623 :nobodyさん:2005/04/21(木) 09:29:33 ID:???
<% を <? 書いたりしちゃうんだろ?

624 :nobodyさん:2005/04/21(木) 11:08:15 ID:???
jspに<%書くことなんかほとんどありません。

625 :nobodyさん:2005/04/21(木) 13:35:19 ID:???
php1色どころか・・

626 :nobodyさん:2005/04/21(木) 13:48:09 ID:???
PHPは本日をもって終了致しました。あざーっす!

627 :nobodyさん:2005/04/21(木) 15:39:36 ID:???
PHPは改装中です。
が、営業中なのです!

628 :nobodyさん:2005/04/21(木) 16:56:02 ID:???
アンチ PHP の必死さが
PHP5 の素晴らしさを証明した

629 :nobodyさん:2005/04/21(木) 16:59:49 ID:???
PHPが素晴らしいなんて言ってるのは某AAACAFEの連中だけだろw
あそこlivedoorに買収されて傘下に入ったけど肝心のlivedoorに相手に
されなくていまだに新規ユーザー募集ができてないんだぜ
http://fh.aaacafe.ne.jp/

630 :nobodyさん:2005/04/21(木) 17:40:27 ID:9MPKObNf
PHP5は好きであるが、好きと実用的かは別なんだよな、広い意味で今は4が無難かな

631 :nobodyさん:2005/04/21(木) 17:42:46 ID:9MPKObNf
更にPerlは好きではないが、安心ではある

632 :nobodyさん:2005/04/21(木) 18:59:41 ID:???
ああそうだよ、おれはアンチPHP5のPHP4信者さ。

633 :nobodyさん:2005/04/21(木) 19:10:36 ID:???
俺はPHP5は好きだがせっかくの良いものを台無しにした
Zendのアホにムカついている。

634 :nobodyさん:2005/04/21(木) 19:37:30 ID:???
>>633
具体的に

635 :nobodyさん:2005/04/21(木) 19:39:58 ID:???
>>630
4はもうゴミ。5の方が圧倒的に実用的。

636 :nobodyさん:2005/04/21(木) 20:33:12 ID:???
>>635
同感。
PHP5 が理解できないので荒れているだけだろ。

637 :nobodyさん:2005/04/21(木) 20:38:25 ID:???
>>634
ZendがPHP5を普及させる努力を怠ったから今のPHP5の現状があるんだよ。
もうこれはParrotの降臨を待つしかPHPの未来は無いね。

638 :nobodyさん:2005/04/21(木) 20:45:17 ID:???
ZendがPHP5をと何度も書き込んでいる人がいるけど、
採用しなかったのは各ディストリ制作者だろ。

639 :nobodyさん:2005/04/21(木) 21:17:33 ID:9MPKObNf
専鯖なら4でも5でもいいがレン鯖を使おうとすると5はきつい。さらにバ―ジョンアップの度に修正が発生するのは発注者も嫌がるね。だって5のレン鯖ほとんど無いからね、別にスクリプトがいいとか悪いとかの話じゃないんじゃないかな。

640 :nobodyさん:2005/04/21(木) 21:23:26 ID:9MPKObNf
広まるかどうかは、単に底辺の利用者が少しづつ増えないときつい訳で国内や海外でもレン鯖の大部分は4なわけで。全て5に移行しても問題無ければ、すぐ5にするんだけどね、毎回バ―ジョンアップで互換性保障出来ないのは、きっついわ

641 :nobodyさん:2005/04/21(木) 21:54:47 ID:???
既存の鯖でアップグレードするから問題あるんでしょ
完全な新規鯖はPHP5でスタートすれば宜しい
あとは100年もすれば変わるだろ

642 :nobodyさん:2005/04/21(木) 22:09:41 ID:???
つうか、PHPをCGIで動かすならPHP4とPHP5は共存出来るんだし、
何を問題にしてるんだ?

実際、某鯖ではPHP4とPHP5はどっちでもつかえるしな。

643 :nobodyさん:2005/04/21(木) 22:24:24 ID:???
PHP最高!

644 :nobodyさん:2005/04/21(木) 22:44:37 ID:???
>>642
>つうか、PHPをCGIで動かすならPHP4とPHP5は共存出来るんだし、
>何を問題にしてるんだ?
PHP5でPHP4のコードのすべてが動くわけではない。
だからPHP5への移行に踏み切れない。それが問題だろ。

645 :nobodyさん:2005/04/21(木) 22:48:13 ID:???
>>644
俺が言ってる事、理解してる?
PHPをCGIで動かすという前提なら、鯖にPHP5もPHP4も一緒に入れられるって言ってるんだよ。
PHP5に移行とかする必要無い。
PHP4で作ったものはPHP4で動かして、
PHP5用に作ったものはPHP5でそれぞれ動かせば良いってだけ。

頭硬いなぁ・・・

646 :nobodyさん:2005/04/21(木) 22:52:01 ID:9MPKObNf
4と5対応のレン鯖がほとんどないじゃん。

647 :nobodyさん:2005/04/21(木) 23:45:12 ID:???
>645みたいな馬鹿はほっておこう

648 :nobodyさん:2005/04/22(金) 00:46:30 ID:???
>>645は、PHP5はCGIでも許される程度のサイトでしか使うなってことが言いたいんですよ。

649 :nobodyさん:2005/04/22(金) 01:10:18 ID:???
誰でもいいからPHP5でPHP4のコードが問題なく動くような
プラグイン的なものを作れや。こんな状況だと本当にPHP終了しちゃうよ?

650 :nobodyさん:2005/04/22(金) 01:22:54 ID:S+4QtOB3
このまま行ったら国内は4からの移行は下手したら10年かかる。何か対策は欲しいものだな

651 :nobodyさん:2005/04/22(金) 01:37:40 ID:???
全ての人が自作でPHP書いてるわけじゃないからなぁ。
作って他の人に配布してる人とかは、色々考慮して作らないといけないからね。

652 :nobodyさん:2005/04/22(金) 07:12:19 ID:???
>>650
頭の悪い読みだな…。自分の頭の悪さの対策をしといたほうがいいぞ。

653 :nobodyさん:2005/04/22(金) 08:14:51 ID:???
PHP3→PHP4の時も結構バタバタしてたようだけど、結局PHP4へ移行したんだよね。
Zendにしてみれば、PHP5の時もそのまま「泳げない奴は沈めばいい」なんだろう。

654 :nobodyさん:2005/04/22(金) 09:11:58 ID:???
そして誰も居なくなった

655 :nobodyさん:2005/04/22(金) 09:12:44 ID:???
ここでホワイトナイト登場

656 :nobodyさん:2005/04/22(金) 10:01:38 ID:???
Zendに危機感が無い限りPHP5が表舞台に立つことはないだろうな。

657 :nobodyさん:2005/04/22(金) 10:18:24 ID:???
perl4 と perl5 の時も同じ話をしてたなぁ

658 :nobodyさん:2005/04/22(金) 10:34:55 ID:???
>>653
PHP4のときは、セッションというキラー機能があったし、性能もあがった。
日本語対応もまともになったし。
PHP5にはPHP5じゃないとできないことが全く無い。

659 :nobodyさん:2005/04/22(金) 12:31:23 ID:+05g+jDp
大手のレンタルサーバ管理者がもっと思い切って
〜日からPHP5にしますので4でしか動かない人は今のうちに何とかしてくださいね♪
ってやってくれればいいんだよ。
一つのサーバがそれやっても他へ移ってしまうだけなので
大手レンタルサーバの管理者たちが皆集まって協力して同時にアップデートするの。

660 :nobodyさん:2005/04/22(金) 13:10:53 ID:???
PHP5 はまともな OO なので
PHP4 より開発効率が素晴らしく向上してますが。
あと、PHP4 より高速だしね。

661 :nobodyさん:2005/04/22(金) 15:40:46 ID:???
巷のレン鯖の導入率が50%程度越えればすぐにでも移行するつもりだよ。

662 :nobodyさん:2005/04/22(金) 15:44:10 ID:???
xrea が PHP5 対応するからそれで十分な気も

663 :nobodyさん:2005/04/22(金) 15:45:07 ID:???
何%よ?

664 :nobodyさん:2005/04/22(金) 15:50:13 ID:???
>>657
Perl4からPerl5への移行は比較的スムーズだったよ。
PHPみたいにガラっと言語仕様が変わったりしてないから。
(Perl5はその点で無理がきちゃったとも言えるが。)
Perl5とPerl6は言語仕様がガラっと変わるけど、
Parrot版Perl5を作るということで対応策は考えてる。

665 :nobodyさん:2005/04/22(金) 15:56:00 ID:???
>>664
PHP4 と PHP5 の「ガラッと」って具体的には?
perl4→5、Java1.1→1.4 より遙かに楽だったんだけど。

666 :nobodyさん:2005/04/22(金) 16:08:44 ID:???
>>665
下位互換性

667 :nobodyさん:2005/04/22(金) 16:11:37 ID:???
下位互換も何も考えずにユーザーガンガン切り捨てる
最新の開発スタイルを貫くZendさんはぶっちゃけカッコイイw
でも、そんなんじゃPHP6を待たずしてPHP撤収→あざーっすの
パターン必至だよねw

668 :nobodyさん:2005/04/22(金) 16:57:43 ID:???
「どの」下位互換を問題にしているの?

665 にも書いたけど perl,java を移植したときの
下位互換性のなさより
PHP4→5 は楽だったんだけど。

669 :nobodyさん:2005/04/22(金) 17:27:52 ID:???
わざわざ書き換えしないと使えないようじゃ、レンタルサーバーで導入渋るのは当たり前。
そういう事考慮してないから、こういう事になるんだよ。

670 :nobodyさん:2005/04/22(金) 17:31:41 ID:???
>>669
だから、それってPHPだけだっけ?
Perlも同じだった気がするんだけど?



671 :nobodyさん:2005/04/22(金) 17:51:32 ID:???
Perl4->5はきつかったけどなぁ、構文変わってたしw
Perl4->5に変わったのってかなり前だし知らないだけでしょ

672 :nobodyさん:2005/04/22(金) 18:03:44 ID:???
Perl4→5 は構文だけでなく、言語仕様変更で
syntax error は出ないんだけど動作がおかしくなる、
なんてあったな。例えば jcode(*) → jcode(\*) とか。

PHP4→5 は変換スクリプト一発で移植完了なので楽すぎ。

673 :nobodyさん:2005/04/22(金) 18:12:01 ID:???
>>672
そうそう、perl は大変だった。
perl は my の導入で local も変わって大変だった。
php と違ってソースの可読性が低いし。

php4→5 は無変更で動くこともある。
実際、同一ソースで php4 と 5 で動くようにしてる。

674 :nobodyさん:2005/04/22(金) 18:45:53 ID:???
うちの掲示板は同じソースで PHP3, 4, 5 で動くよ

675 :nobodyさん:2005/04/22(金) 20:31:08 ID:S+4QtOB3
PerlとPHPじゃ市場利用規模が違いすぎ。広がりかけのスクリプトなんだからさ、PHPはね。Perl使えないレン鯖を借りるか?PHPは使えなくても気にならない奴がほとんど

676 :nobodyさん:2005/04/22(金) 20:33:49 ID:???
>>675
PerlとPHPの市場比のソース希望。
あと、新規案件での採択比希望。

677 :nobodyさん:2005/04/22(金) 20:36:32 ID:S+4QtOB3
今仮にレン鯖全部5にしたら客逃がす、ようなもんだろ。そんな危険犯す鯖屋は少ないぞ、少なくとも4と5選択可じゃないと鯖屋としては危険だろだから4のままなんだよ

678 :nobodyさん:2005/04/22(金) 21:07:40 ID:???
>>677
だからそれは perl の時もそうだったよね?

679 :nobodyさん:2005/04/22(金) 21:16:06 ID:S+4QtOB3
ん?じゃなんで5レン鯖ほとんど無いの?

680 :nobodyさん:2005/04/22(金) 21:31:44 ID:???
>>679
それは、Perl5が出てからも暫くレン鯖無かったのと同じ。


681 :nobodyさん:2005/04/22(金) 21:39:39 ID:S+4QtOB3
信者は話出来ないんだな。これにて5終了でいいかな

682 :nobodyさん:2005/04/22(金) 21:44:57 ID:???
国内でないだけだろ
アメリカにはある
日本はアメリカの数年遅れなだけ
PHP4 や Perl5 の時も同様

683 :nobodyさん:2005/04/22(金) 23:05:41 ID:???
PHP信者は何を根拠に妄想ばかりほざいているのでしょうか?

684 :nobodyさん:2005/04/22(金) 23:38:02 ID:???
アンチは何を根拠に妄想ばかりほざいているのでしょうか?

685 :nobodyさん:2005/04/23(土) 01:22:29 ID:yHGL8I0/
ま―どっちでもいがな俺は5は好きだし広まって欲しいよ、ただあまり早い速度で下位互換ないと仇になる場合が多いのはわかるだろ?そしてレン鯖で言えば、現状は4な訳よ、これが一気に5にはならない訳よわかるだろ?

686 :nobodyさん:2005/04/23(土) 01:27:21 ID:yHGL8I0/
レン鯖で言えば、おそらく4と5両方使えないと、加入者も困る訳、さらにこうなるとPHPじゃなくてもいい訳。信者も視野を広げて意見が欲しいもんだね

687 :nobodyさん:2005/04/23(土) 01:35:31 ID:yHGL8I0/
更に今どっかの素人のレン鯖使いが、どっかになんかのスクリプト依頼して5で出来てきたら鯖4なんですけどってなるだろ。

688 :nobodyさん:2005/04/23(土) 01:42:24 ID:yHGL8I0/
だから広まりかけてるPHPは完全に下位互換ないと、まんどくさくてだるい訳、ま―とは言っても、それが方針だからしょうが無いがなハァハアだって今だぞ今!今5で納品したら、ぶっちゃけバグもありそうだしな

689 :nobodyさん:2005/04/23(土) 01:42:50 ID:???
レン鯖使ってるようなトーシロ連中が気にするような話題じゃないと思うがな( ´,_ゝ`)

690 :nobodyさん:2005/04/23(土) 01:45:15 ID:yHGL8I0/
ぶっちやけレン鯖じゃ無ければ、5が最高に決まってる。専鯖なら好きなバ―ジョン使えばいいだけの話だしな

691 :nobodyさん:2005/04/23(土) 01:50:09 ID:???
>>689
専用サーバー使えるなら、中途半端なOOで次のバージョンアップで動く保証のないPHP5使う
よりJavaのほうがいい。
開発環境が整ってて開発も楽だしね。

692 :nobodyさん:2005/04/23(土) 01:55:08 ID:???
>>678,680
PHP5のRCからすでに1年が過ぎ、もうすぐ正式リリースから1年になろうかという時期じゃなければ説得力があるんだけどね。

693 :nobodyさん:2005/04/23(土) 02:15:40 ID:???
だからごちゃごちゃ言わずにZendのバカがPHP5でPHP4も動くような
オプションをつければいいんだよボケ。

694 :nobodyさん:2005/04/23(土) 02:37:57 ID:???
本来なら、先進的にPHP5を採用する人がメリットを享受してることを宣伝して、保守的な人が重い腰をあげる気配が見えはじめないといけないんだよね。

695 :nobodyさん:2005/04/23(土) 08:50:34 ID:???
>>693
これじゃだめなの(php.ini)
; Enable compatibility mode with Zend Engine 1 (PHP 4.x)
zend.ze1_compatibility_mode = On

696 :nobodyさん:2005/04/23(土) 09:52:12 ID:???
>>695
勉強不足で申し訳ないんだけど
それでPHP4のどのようなソースも動くようになるの?

697 :nobodyさん:2005/04/23(土) 09:55:08 ID:yHGL8I0/
動く場合もある、保障はない。俺試したら駄目な場合が多いわ

698 :nobodyさん:2005/04/23(土) 16:13:18 ID:???
まったくZendの仕事は雑だなぁ。

699 :nobodyさん:2005/04/23(土) 16:47:15 ID:???
思いつきでやってるんだと思うよ

700 :nobodyさん:2005/04/23(土) 17:15:54 ID:???
>>699
ジャニー喜多川みたいだな。

701 :nobodyさん:2005/04/23(土) 22:23:39 ID:???
互換モードで何の問題なく動いてるなぁ。
動かない配布されているアプリとかって何かある?

702 :nobodyさん:2005/04/23(土) 22:43:25 ID:???
ZendがPHP5で下位互換性をないがしろにした、と騒いでいる阿呆どもは
なんでわざわざこのスレを覗きにきてるわけ?


703 :nobodyさん:2005/04/24(日) 00:12:44 ID:???
タイトルのような書き込みが殆ど無いので
再利用。

704 :nobodyさん:2005/04/24(日) 00:19:37 ID:f4eyzcbj
PHP5の機能全部入れアプリ作り始めるの
('A`)| ̄|_マンドクセになってる香具師いるだろ?

705 :nobodyさん:2005/04/24(日) 01:40:11 ID:Zg/1W/4F
ってかさ信者以外わざわざPHP5使う必要あるか?6になっても7になってもどうせ、同じく下位互換保障ないかもだぜ、Perlも他言語もそ―じゃんとか言ってる奴は使った事ないやつだろ、現実知れよ信者。

706 :nobodyさん:2005/04/24(日) 01:43:43 ID:Zg/1W/4F
質問する前にちゃんと自分で調べてから言ってほしいわ。

707 :nobodyさん:2005/04/24(日) 01:47:25 ID:???
>>705
>Perlも他言語もそ―じゃんとか言ってる奴は使った事ないやつだろ、現実知れよ信者。

むしろ、お前がPerlも使った事の無いんじゃないか?
さらに現実を見るのはお前さんだろ。

俺だけじゃないだろうが、Perlもそうだったと言ってるのは、
以前はPerlを使っていて、そういった現実を見てきた・体験してきたんだよ。

>ってかさ信者以外わざわざPHP5使う必要あるか?6になっても7になってもどうせ、同じく下位互換保障ないかもだぜ

Perlも6になってどうなるか見ものだよな。
今のPHP5に対して言ってる事と全く同じ事言われそうだな。
ちなみに、Perl5が出てきた時も、殆ど同じような意見が出されたよ。

708 :nobodyさん:2005/04/24(日) 01:53:43 ID:Zg/1W/4F
ぷっどこがどう違ったかソ―ス希望

709 :nobodyさん:2005/04/24(日) 12:20:50 ID:???
つーか例外処理も無いPHP4なんか使い物にならねーんだよ。

710 :nobodyさん:2005/04/24(日) 12:32:02 ID:???
だからJava使うんだろ。

711 :nobodyさん:2005/04/24(日) 14:29:06 ID:???
一度死んで蘇れば良いと思うよ

712 :nobodyさん:2005/04/24(日) 20:47:36 ID:???
ハッカーは Java を使わない

713 :nobodyさん:2005/04/24(日) 21:17:12 ID:???
Javaはいちいちコンパイル&デプロイするの面倒だしな。


714 :nobodyさん:2005/04/24(日) 22:00:20 ID:???
面倒ならAntで自動化すればいいだけじゃない?
まともな開発環境なら、開発時はコンパイルとかデプロイとか意識する必要ないし。

715 :nobodyさん:2005/04/24(日) 22:01:01 ID:???
Javaはトロくさいよ

716 :nobodyさん:2005/04/24(日) 22:10:08 ID:???
そりゃキミのPentium166MHzでは重かろう。

717 :713:2005/04/24(日) 22:21:00 ID:???
>>714
当然AntもXDocletも使ってるけど、「コンパイルとかデプロイとか意識する必要はない」と
「コンパイルやデプロイが必要ない」ってのは大きな違いですよ。



718 :nobodyさん:2005/04/24(日) 22:36:39 ID:???
Java使いには雑魚が多い。

719 :nobodyさん:2005/04/24(日) 23:11:37 ID:???
PHP使いには?

720 :nobodyさん:2005/04/24(日) 23:15:48 ID:???
イケメンが多い。

721 :nobodyさん:2005/04/24(日) 23:50:08 ID:???
>>717
XDocletはコンパイルやデプロイには関係ないと思うが・・・
で、コンパイルとかデプロイとか意識する必要ないまともな開発環境は使ってるの?
コンパイルやデプロイが必要ないのと大きな違いは無いと思うけど。
デプロイに関しては、開発時にローカルでやる分には基本的に必要ないわけで。

722 :nobodyさん:2005/04/25(月) 00:03:50 ID:???
Eclipseとか使ってればWebアプリでコンパイルを意識しないけどなあ。

723 :nobodyさん:2005/04/25(月) 00:07:20 ID:???
いや、開発時においては意識してもらわないと、その、困る

724 :nobodyさん:2005/04/25(月) 02:23:15 ID:???
Eclipse使っててJava知ってるとなんかPHP5やる気なくす・・・。俺は。
むしろわりきってPHP4が好きなのかも。

725 :nobodyさん:2005/04/25(月) 02:41:27 ID:???
PHP5のオブジェクト指向ってJava使いからみるとそんなに劣ってるの?

726 :nobodyさん:2005/04/25(月) 02:59:15 ID:???
いや、PHP5は素材としては良いと思います。
劣ってると思う部分はそれをとりまく環境です。
Eclipse, tomcat, struts, Junitなど、その他もろもろのツールを使ってみてください。
Javaは冗長で面倒くさく小回りが効かないのが欠点だけど、良いですよ。
でも、オブジェクト指向になれてないと、
便利なツールもとっつきにくい、というかありがたみがわからないかも。
PHP5のオブジェクト指向は局所的に便利に使おうと思います。

727 :713:2005/04/25(月) 06:03:23 ID:???
>>721
いや、XDocletはHibernateのマッピングファイル生成に使ってるんだけど
この作業はコンパイル時に平行して行う必要があるので関係あるんです。
むしろXDocletがサポートする領域って、どれもコンパイル/デプロイ時に
意識する必要があるものばかりだと思うけどな。

開発環境はEclipse使ってますよ。 
俺が言ってるのは運用環境に最新のコードを反映させる際に、いちいち
コンパイル&デプロイする手間がPHPに比べて冗長だってこと。






728 :nobodyさん:2005/04/25(月) 09:54:42 ID:???
Java と PHP を使うけど
Emacs 使いとしては Eclipse は不便。
Java も PHP も Emacs で満足。

あと、Java の OO は冗長で開発効率と精神性に悪くない?

729 :nobodyさん:2005/04/25(月) 11:03:18 ID:???
PHPのOOは、Javaのマネで、型なし言語のよさも活かしてないし、型あり言語の制約だけ持ち込んでる。

730 :nobodyさん:2005/04/25(月) 11:04:58 ID:???
>>727
運用環境に最新のコード反映させるのなんか、warファイル置くだけじゃないか。

731 :nobodyさん:2005/04/25(月) 11:15:26 ID:???
つうか、EclipseってWeb開発には普通に不便。
JBuilderかNetBeansの方がいい。

732 :nobodyさん:2005/04/25(月) 11:40:48 ID:???
色々使うけど、結局は慣れの気がする。

733 :nobodyさん:2005/04/25(月) 11:46:21 ID:???
VS を知ると Eclipse や JBuilder 全て不便

734 :nobodyさん:2005/04/25(月) 11:56:59 ID:???
>>733
言語云々とかは置いておいて、MSのVSだけは優秀だよな。
VSの環境以外に考えられないもんな・・・

735 :nobodyさん:2005/04/25(月) 21:42:54 ID:???
MSのユーザーインターフェイスは優秀だと思う。
MSが買収したソフトは、ユーザーインターフェイスだけはよくなるね。

736 :nobodyさん:2005/04/25(月) 21:44:13 ID:HOVPxGDh
なぜUIと言わないのだろう

737 :nobodyさん:2005/04/25(月) 21:49:30 ID:???
なぜ何故と書かないのだろう?

738 :nobodyさん:2005/04/25(月) 22:33:50 ID:aA4dYCfi
なぜ何故と書かないのだらう?と書かないのでせうか?

739 :nobodyさん:2005/04/25(月) 22:50:38 ID:???
なぜ何故と書かないのだらう?と書かないのでせうか?
を略して
な??

740 :nobodyさん:2005/04/26(火) 01:56:49 ID:???
1-739
を略して
PHPはもう終わりです

741 :nobodyさん:2005/04/26(火) 02:17:13 ID:???
>>740
自分の無知を晒さなくても…

742 :nobodyさん:2005/04/26(火) 02:18:36 ID:???
>>741
すまん。無知だった。
ちゃんと調べたら、PHPはすでに終わってた。

743 :nobodyさん:2005/04/26(火) 02:29:01 ID:???
EclipseでPHP5書いてるけど
普通に便利だよ
OOPだとクラスファイルがやたら増えるから
エディタだけだとキツいと思う

744 :nobodyさん:2005/04/26(火) 04:49:06 ID:???
ところでPHP5ではコネクションプーリングできるようになったの?

745 :nobodyさん:2005/04/28(木) 23:46:58 ID:eAvi3RWA
php5-cliってドコでダウンロードできるのかね?
php.netに見当たらないんだけど。

746 :nobodyさん:2005/05/11(水) 23:25:39 ID:eSRE9XL0
>>744
http://66.102.7.104/search?q=cache:z4Yyc0rmnFQJ:www.freespace.jp/~Pooh/WEB%2BDB-PRESS18-Toku3-3-3.pdf+%E3%82%B3%E3%83%8D%E3%82%AF%E3%82%B7%E3%83%A7%E3%83%B3%E3%83%97%E3%83%BC%E3%83%AA%E3%83%B3%E3%82%B0+php&hl=ja

747 :nobodyさん:2005/05/12(木) 01:25:59 ID:???
>>743
入力補完ってある?

748 :nobodyさん:2005/05/12(木) 15:23:54 ID:???
>>747
あるよ

749 :nobodyさん:2005/05/13(金) 12:11:18 ID:???
いつまで待てばphp5によるphp1色の時代になりますか?

750 :nobodyさん:2005/05/13(金) 12:41:22 ID:???
目をつぶれ。
まぶたの上から人差し指で両目を思いっきりおさえろ。
30秒待て。
指を離して目を開けろ。

ほら、PHP1色の世界が見えただろ?

751 :nobodyさん:2005/05/13(金) 16:25:27 ID:???
>>750
言われたとおりやってみました。
PHP5のおかげで崩壊しつつあるPHPの姿が見えました。

752 :nobodyさん:2005/05/13(金) 16:45:45 ID:???
どうやらまだ目を開いていない様子

753 :nobodyさん:2005/05/14(土) 00:29:49 ID:???
>>752
それはあんただ。
しっかりと目を見開いて現状を見てみな。
だーれもPHP5を使ってないから。
そしてそんな現状を作り出したZendに対する不信感が
PHPユーザーのPHP離れを招いているんだよ。

754 :nobodyさん:2005/05/14(土) 01:59:13 ID:???
Zendは開発者を大切にするとか言った事ないよね。
MSにしろSunにしろIBMにしろ、本音はどうあれ開発者を大切にすると言ってる。

755 :nobodyさん:2005/05/14(土) 03:19:02 ID:???
>>754
ZendがMSやSunやIBMと肩を並べようとは片腹痛いんだが。
ちなみにMSやSunはPHPのようにマイナーバージョンアップで
互換性が取れないような失態はしてないがそこら辺のアンタの
意見を聞かせてくれないか?

756 :nobodyさん:2005/05/14(土) 08:37:01 ID:???
なにを求めてるのかわからんのだが。
MSやSunは、マイナーバージョンアップで互換性が取れないような「失態」を何度かしている。
でも、それは、保証しようとしたことが失敗したので、PHPの場合のマイナーバージョンアップでの互換性をはなから保証していないのとは違う。
つまり、PHPのマイナーバージョンアップで互換性がとれなくても、失態でも失敗でもなく、当たり前の正常な現象。
やってられない。

757 :nobodyさん:2005/05/16(月) 15:06:44 ID:???
>>753
「だーれもPHP5を使ってないから。 」

は?

758 :nobodyさん:2005/05/16(月) 16:28:49 ID:???
「だーれもPHP5を使ってないから。 」

に?

759 :nobodyさん:2005/05/16(月) 17:21:17 ID:???
Google くらいすればいいのにね

760 :nobodyさん:2005/05/16(月) 21:30:06 ID:???
今の時代誰もGoogleなんて使わんだろ
みんなGooglke使ってるよ

761 :nobodyさん:2005/05/16(月) 23:21:45 ID:???
私はGoogleを使っていますが。

762 :nobodyさん:2005/05/17(火) 14:50:58 ID:???
で?いつになったらPHP5によるPHP1色の時代になんのよ?
またガセか?

763 :nobodyさん:2005/05/17(火) 22:42:33 ID:???
その前に、PHPがPHP5一色にならんのか?

764 :nobodyさん:2005/05/18(水) 08:29:52 ID:???
ははは、この小僧め、痛いところをつきよる

765 :nobodyさん:2005/05/20(金) 01:54:44 ID:???
3年後にはきっと!

766 :nobodyさん:2005/05/20(金) 05:10:09 ID:???
PHP6がでてるはずなのに、PHP5一色です!

767 :nobodyさん:2005/05/22(日) 13:09:26 ID:???
PHP5いつになったら普通のレン鯖で使えるようになるのかねぇ・・・

768 :nobodyさん:2005/05/22(日) 15:13:15 ID:???
明日から全国一斉に

769 :nobodyさん:2005/05/22(日) 18:44:17 ID:???
わくわくするぞ

770 :nobodyさん:2005/05/24(火) 22:37:25 ID:???
どきどき

771 :nobodyさん:2005/05/25(水) 01:35:02 ID:???
ハラハラ

772 :nobodyさん:2005/05/25(水) 07:10:49 ID:???
ガッカリ

773 :nobodyさん:2005/05/26(木) 22:11:52 ID:???
萌えー

774 :nobodyさん:2005/06/04(土) 17:48:02 ID:???
一向に来る気配の無いPHP51色の時代w

775 :nobodyさん:2005/06/04(土) 18:59:13 ID:???
PHP五十一色の時代。カラフル。

776 :nobodyさん:2005/06/11(土) 14:00:28 ID:???
正直PHP4をやりこめばやりこむほどOOの不完全さが身にしみる。
はよPHP5を普及させてくれ。そこいらのレン鯖にインスコされる程度に。

777 :nobodyさん:2005/06/11(土) 21:49:06 ID:???
正直JavaやRubyをやりこめばやりこむほどPHP5の不完全さが身にしみる。
はよRubyを普及させてくれ。そこいらのレン鯖にインスコされる程度に。

778 :nobodyさん:2005/06/12(日) 02:53:04 ID:???
>>777
RubyがWebで使えるようになるかはParrotにかかってる。
期待して待ってるんだな。

779 :nobodyさん:2005/07/05(火) 10:42:32 ID:???
PHP5とかとっとと捨ててPHP6をParrotで作ればいいんじゃまいか?
PHP4とPHP5の互換関数と互換構文を実装しておけば、PHP4やPHP5からの移行も楽だろうし
JavaやPerlやPythonやRubyやTclに切り替えたくなったら簡単に切り替えられるし
PHP6の機能がいらなければ、PHP4やPHP5のみを実装した上位言語を選べばいいだけだし。
だから、PHPもZendエンジンとか捨てて、Parrotに参加しろってこった!

780 :nobodyさん:2005/07/07(木) 15:42:45 ID:???
PHP5一向に盛り上がりませんねぇw

781 :nobodyさん:2005/07/13(水) 16:32:08 ID:???
PHP4には、はぁはぁスレがあるのに、PHP5にはないからだ。

782 :nobodyさん:2005/07/21(木) 21:22:31 ID:???
PHP5の時代?すでに終了致しました。

783 :nobodyさん:2005/08/05(金) 09:20:22 ID:???
バージョンアップする度に動かなくなるのは何とかしてくれ。
言語仕様クソ過ぎだよ。

784 :nobodyさん:2005/08/05(金) 13:33:19 ID:???
まあ、普通はバージョンアップ前にChangeLog読むだろうから
エンバグしてない限りそんなに問題はない。

785 :nobodyさん:2005/08/05(金) 19:22:12 ID:???
エンバグも多いし、change_log読んで
「仕様変更がありました」
って書かれてて問題ないわけない。

786 :nobodyさん:2005/08/05(金) 19:28:57 ID:???
>>785
考え方の違い。

『仕様変更ありました』と書かれていたら、今現在のシステムなりに影響があるかを考える。
影響があるなら、セキュリティなどの深刻な問題があったかを更に調べ、
特に問題がなかったり、PHPの書き方とかで回避できるのであれば、バージョンアップを見送る。

だから、そんなに問題になる訳が無い。

787 :nobodyさん:2005/08/05(金) 19:30:58 ID:???
つうか、こういう所はASP.NETを見習って欲しいよな・・・
複数のバージョンの.NETFrameworkは同時にインストールできるし、
動かす時は、どれを使うか選べるしで、かなり楽だよな。

788 :nobodyさん:2005/08/05(金) 19:52:41 ID:???
>>786
お前のチンケなシステムの話はしていない

789 :nobodyさん:2005/08/05(金) 19:59:44 ID:???
>>788
それほど重要なシステムなのに、調べもせずにバージョンアップして動かないとか行ってる時点で、
そのシステムがどれだけチンケなものか想像し易いなw

790 :nobodyさん:2005/08/05(金) 21:34:40 ID:???
後先考えずに手っ取り早く組むにはPHPが一番!

791 :nobodyさん:2005/08/05(金) 23:41:27 ID:???
>>786
セキュリティアップデートで最新版以外使えなくなるにもかかわらず影響がある変更が入ってることが多々あるわけだが。

792 :nobodyさん:2005/08/06(土) 05:24:10 ID:???
>>789
あほかお前

793 :nobodyさん:2005/08/17(水) 13:21:29 ID:jK+iF8Wk
php5ってJavaみたいにクラス内でメンバ変数やメソッドにアクセスする際の
$this->の省略ってできる?$thisマジうざいんだけど。


794 :nobodyさん:2005/08/17(水) 19:18:39 ID:???
>>793
できない。
ドキュメントも読まない奴が一番うざい。

795 :nobodyさん:2005/08/29(月) 01:59:53 ID:k81lo1zL
PHP4.xとPHP5.0とPHP5.1の速度の比較がある。
http://ll.jus.or.jp/2005/files/php-llm05.pdf/file_view
これ見る限りPHP5.1でphp1色の時代になるのは間違いなさそう。


796 :nobodyさん:2005/08/29(月) 02:36:22 ID:???
PHP6でとうとうregister_globalsは削除されちゃうんだね。

797 :nobodyさん:2005/08/29(月) 02:37:34 ID:???
投票でも圧倒的多数で賛成かw>削除

798 :nobodyさん:2005/08/29(月) 06:36:43 ID:???
実際いらんだろ
今時ONにしてる奴もいるまい

799 :nobodyさん:2005/08/29(月) 10:22:09 ID:???
なんだかなぁ

民主党の演説だけを聴いて民主党に投票しようと考えてしまうような奴らなんだな、PHP厨って

800 :nobodyさん:2005/08/29(月) 11:01:52 ID:???
病院いけ病院

801 :nobodyさん:2005/08/29(月) 13:35:09 ID:???
削除する理由がわからん。
デフォルトOFFでいいんじゃねぇの?

802 :nobodyさん:2005/08/29(月) 14:32:40 ID:???
セキュリティ問題に気づいていないで
Onにしてる奴を排除したいからでしょ。

803 :nobodyさん:2005/08/31(水) 03:40:15 ID:???
ところで激しく既出だろうがCGIがPHP一色って凄いネタだな。

804 :nobodyさん:2005/11/24(木) 11:41:43 ID:LxL/Yc0H
次スレ?

805 :nobodyさん:2005/11/24(木) 16:26:09 ID:???
>>804
これ
【明暗】金持ちPHP様・貧乏Perl様【格差】
http://pc8.2ch.net/test/read.cgi/php/1132681055/l50


806 :nobodyさん:2005/11/25(金) 03:54:30 ID:???
PHPはHSP化してるな...


807 :nobodyさん:2005/11/29(火) 11:59:33 ID:z9bO3bBH
5.1.0でたばっかなのにもう5.1.1

808 :nobodyさん:2005/11/30(水) 17:23:22 ID:???
>>799
思い込みの激しい子だね

809 :nobodyさん:2005/12/15(木) 19:55:34 ID:???
一向に来る気配すらないPHP5の時代。
もう終わったなw

810 :nobodyさん:2006/01/17(火) 11:01:18 ID:3Dm9/vEX
最近、XREA+借りたら無条件でPHP5でした。
今までPHP4サバ使ってたのでとりあえずそのままアップしてみてたら
ことごとく全部表示すら出来なかった・・・。

そして調べてみるとob_start("ob_gzhandler"); をコメントアウトすると
表示できた。

という事はPHP5でgzip圧縮は駄目になったんでしょうか?


811 :810:2006/01/17(火) 11:46:04 ID:???
すれ違いっぽいのでこちらに移動します。

【PHP】下らねぇ質問はここに書き込みやがれpart15
http://pc8.2ch.net/test/read.cgi/php/1137236771/

812 :nobodyさん:2006/04/20(木) 16:12:22 ID:iuRzPwTn
頻繁に起動されるPHPスクリプトならともかく、たまにしか動かないPHPスクリプトを
わざわざApacheモジュール版PHPで動かすのはバカ。メモリの無駄遣い。

813 :nobodyさん:2006/04/22(土) 12:26:52 ID:???
たまにしか動かないPHPスクリプトだからモジュール版PHPじゃないのか?

814 :nobodyさん:2006/04/22(土) 14:56:03 ID:???
mod_php は Apache::PerlRun のようにインタプリタが常駐するだけって知らずに言ってる気がする。
ちなみに PHP は他の SAPI (たとえば FastCGI) もインタプリタが常駐するだけなので
SAPI が異なっても同様に動くというメリットがある反面、プログラム自体を常駐させるような
使い方はあまりされないね。(Pure PHP で httpd つくったりしてるひともいるにはいるが)

815 :812:2006/04/22(土) 16:37:09 ID:hWAnve9c
ああ、そういうことか。たまにしか動かないスクリプトでmod_perlは論外ね。
俺が言いたいのはインタープリターの常駐もメモリの無駄だってこと。

816 :nobodyさん:2006/04/23(日) 04:06:41 ID:???
それ以前に電気の無駄だからコンセント抜いとけ

817 :nobodyさん:2006/08/10(木) 10:57:00 ID:???
 

818 :nobodyさん:2006/08/10(木) 11:01:34 ID:???
 

819 :nobodyさん:2006/08/10(木) 11:05:10 ID:???
 

820 :nobodyさん:2007/01/29(月) 18:05:08 ID:WdiEljc0
magic_quotes_gpcってデフォでoffになってたのね

161 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.02.02 2014/06/23 Mango Mangüé ★
FOX ★ DSO(Dynamic Shared Object)